BNUOJ 33993 Stealing Harry Potter's Precious(bfs+dfs)

Stealing Harry Potter's Precious

Time Limit: 1000ms
Memory Limit: 32768KB
This problem will be judged on  HDU. Original ID:  4771
64-bit integer IO format:  %I64d      Java class name:  Main
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.

Input

  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0

Output

  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.

Sample Input

2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
0 0

Sample Output

-1
5

刚开始想的是直接用优先队列广搜,搜到每一个宝藏以此为起点再去搜另一个宝藏,但这种方法考虑不到一种情况:
多个宝藏到起点的距离相同,后来又想到另一种思路,干脆把每一个宝藏到另一个宝藏的距离都用广搜搜出来,然后用dfs跑一下从起点遍历所有点的最小总步数。
#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define mem(a,b) memset(a,b,sizeof(a))
#define wtf printf("wtf\n");
#define maxn 105
#define ll long long
using namespace std;
int n,m,q;
int minn;
int sx,sy;
char e[maxn][maxn];
int vis[maxn][maxn];
int book[maxn][maxn];
int flag[6];
int dis[6][6];
int go[5][2]={{1,0},{0,1},{-1,0},{0,-1}};
struct Node
{
    int step,x,y;
    bool friend operator < (Node a,Node b)
    {
        return a.step>b.step;
    }
};
struct node
{
    int x,y;
}t[5];
bool check(int x,int y)
{
    if(x>0&&x<=n&&y>0&&y<=m&&!vis[x][y]&&e[x][y]!='#')
        return 1;
    return 0;
}
void bfs(int k,int x,int y)
{
    Node a,b;
    priority_queue<Node>Q;
    a.x=x;
    a.y=y;
    a.step=0;
    dis[k][k]=a.step;
    vis[x][y]=1;
    Q.push(a);
    int sum=0;
    while(!Q.empty())
    {
        a=Q.top();
        Q.pop();
        for(int i=0;i<4;i++)
        {
            int tx=go[i][0]+a.x;
            int ty=go[i][1]+a.y;
            if(check(tx,ty))
            {
                vis[tx][ty]=1;
                if(book[tx][ty])
                {
                    for(int j=0;j<=q;j++)
                    {
                        if(tx==t[j].x&&ty==t[j].y)
                        {
                            sum++;
                            dis[k][j]=a.step+1;
                            dis[j][k]=a.step+1;
                        }
                    }
                }
                    b.x=tx;
                    b.y=ty;
                    b.step=a.step+1;
                    Q.push(b);
            }
        }
    }
}
void dfs(int num,int sum,int step)
{
    if(sum>minn)return;
    if(step==q)
    {
        minn=min(minn,sum);
    }
    for(int i=1;i<=q;i++)
    {
        if(!flag[i])
        {
            flag[i]=1;
          if(dis[num][i]<0)
           continue;
            dfs(i,sum+dis[num][i],step+1);
            flag[i]=0;
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&n+m)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%s",e[i]+1);
            for(int j=1;j<=m;j++)
            {
                if(e[i][j]=='@')
                {
                    t[0].x=i;
                    t[0].y=j;
                }
            }
        }
        mem(book,0);
        scanf("%d",&q);
        for(int i=1;i<=q;i++)
        {
            scanf("%d %d",&t[i].x,&t[i].y);
            book[t[i].x][t[i].y]=1;
        }
        mem(dis,-1);
        for(int i=0;i<=q;i++)
        {
            mem(vis,0);
            bfs(i,t[i].x,t[i].y);
        }
        mem(flag,0);
        minn=0x3f3f3f3f;
        dfs(0,0,0);
        if(minn==0x3f3f3f3f)
            printf("-1\n");
        else
       printf("%d\n",minn);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值