HDU 4771 Stealing Harry Potter's Precious (bfs+dfs)

Stealing Harry Potter’s Precious

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3383 Accepted Submission(s): 1525

Problem Description
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon’s home. But he can’t bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)….. A 3×4 bank grid is shown below:

  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers’ properties, so they live in the indestructible rooms and put customers’ properties in vulnerable rooms. Harry Potter’s precious are also put in some vulnerable rooms. Dudely wants to steal Harry’s things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can’t access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry’s precious are. He wants to collect all Harry’s precious by as less steps as possible. Moving from one room to another adjacent room is called a ‘step’. Dudely doesn’t want to get out of the bank before he collects all Harry’s things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry’s precious.

Input
  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<\N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. ‘#’ means a indestructible room, ‘.’ means a vulnerable room, and the only ‘@’ means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter’s precious in the bank.
  In next K lines, each line describes the position of a Harry Potter’s precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0

Output
  For each test case, print the minimum number of steps Dudely must take. If Dudely can’t get all Harry’s things, print -1.

Sample Input
2 3
##@
#.#
1
2 2
4 4
#@##
….
####
….
2
2 1
2 4
0 0

Sample Output
-1
5

Source
2013 Asia Hangzhou Regional Contest
HDU原题。。16北京区域赛热身赛这题。。热身赛的时候死都调不出来这题,好气啊。。。回来发现memset里面参数写成sizeof(0)。。。然后就过了

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"
#include "set"
#include "queue"
#include "cmath"
using namespace std;
typedef struct node
{
    int x,y;
}node;
typedef struct status
{
    int x,y,step;
}status;
char mmap[105][105];
int vis[105][105];
int n,m;
node s;
queue<status> s_list;
node ed_list[10];
int bfs(node start,node end)
{
    memset(vis,0,sizeof(vis));
    while(!s_list.empty())
        s_list.pop();
    status t;
    t.x=start.x;
    t.y=start.y;
    t.step=1;
    vis[t.x][t.y]=1;
    s_list.push(t);
    while(!s_list.empty())
    {
        status now=s_list.front();
        s_list.pop();
        if(now.x==end.x&&now.y==end.y)
        {
            return now.step-1;
        }
        if(mmap[now.x+1][now.y]!='#'&&vis[now.x+1][now.y]==0&&now.x+1<=n)
        {
            vis[now.x+1][now.y]=now.step+1;
            status temp;
            temp.x=now.x+1;
            temp.y=now.y;
            temp.step=now.step+1;
            s_list.push(temp);
        }
        if(mmap[now.x-1][now.y]!='#'&&vis[now.x-1][now.y]==0&&now.x-1>=1)
        {
            vis[now.x-1][now.y]=now.step+1;
            status temp;
            temp.x=now.x-1;
            temp.y=now.y;
            temp.step=now.step+1;
            s_list.push(temp);
        }
        if(mmap[now.x][now.y+1]!='#'&&vis[now.x][now.y+1]==0&&now.y+1<=m)
        {
            vis[now.x][now.y+1]=now.step+1;
            status temp;
            temp.x=now.x;
            temp.y=now.y+1;
            temp.step=now.step+1;
            s_list.push(temp);
        }
        if(mmap[now.x][now.y-1]!='#'&&vis[now.x][now.y-1]==0&&now.y-1>=1)
        {
            vis[now.x][now.y-1]=now.step+1;
            status temp;
            temp.x=now.x;
            temp.y=now.y-1;
            temp.step=now.step+1;
            s_list.push(temp);
        }

    }
    return -1;
}
int ans;
int flag=1;
int v[10];
void dfs(int lastsum,node lastpos)
{
    int mark=0;
    for(int i=1;i<flag;i++)
    {
        if(v[i]==1)
            mark++;
    }
    if(mark==flag-1)
    {
        ans=min(ans,lastsum);
        return;
    }
    for(int i=1;i<flag;i++)
    {
        if(v[i]==0)
        {
            v[i]=1;
            int temp=bfs(lastpos,ed_list[i]);
            if(temp==-1)
            {
                continue;
            }
            else
                dfs(lastsum+temp,ed_list[i]);
            v[i]=0;
        }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m))
    {
        if(n+m==0)
            return 0;
        for(int i=1;i<=n;i++)
        {
            scanf("%s",mmap[i]+1);
            for(int j=1;j<=m;j++)
            {
                if(mmap[i][j]=='@')
                {
                    s.x=i;
                    s.y=j;
                }
            }
        }
        int k;
        flag=1;
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
        {
            node now;
            scanf("%d%d",&now.x,&now.y);
            int myflag=0;
            for(int j=1;j<flag;j++)
            {
                if(now.x==ed_list[j].x&&now.y==ed_list[j].y)
                {
                    myflag=1;
                }
            }
            if(myflag==0)
            {
                ed_list[flag].x=now.x;
                ed_list[flag++].y=now.y;
            }
        }
        ans=999999999;
        for(int i=1;i<flag;i++)
        {
            memset(v, 0, sizeof(v));
            v[i]=1;
            int temp=bfs(s,ed_list[i]);
            if(temp!=-1)
                dfs(temp,ed_list[i]);
            v[i]=1;
        }
        if(ans==999999999)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值