Poj 3255 Roadblocks【次短路】【大一最后一题】

Roadblocks

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 11863

 

Accepted: 4183

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 
Lines 2..R+1: Each line contains three space-separated integers: AB, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4

1 2 100

2 4 200

2 3 250

3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

Source

USACO 2006 November Gold

 

题目大意:


求一条从1到n的次短路。


思路:


经典的题,做一道少一道,Acm的日子,过一天少一天,大一结束了,大二还远吗?



1、对于一条边,s-e,那么求一条从1到n的次短路,其实就是相当于求:从1到s的最短路+从e到n的最短路+s-e的边权值。


2、那么对于一个无向图,从1到s的最短路求一遍以1作为源点的单源最短路即可,那么从e到n的最短路呢?逆向思考一下,对于无向图,其实就是求一遍从n到e的最短路,那么解这个题,就是先求两边最短路,然后每条边枚举一下即可。


3、枚举每一条边,维护次小值即可。


Ac代码:


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int vis[1000000];
int head[100000];
struct EdgeNode
{
    int from;
    int to;
    int w;
    int next;
}e[1000000];
int dis[2][100000];
int n,m,cont;
void add(int from,int to,int w)
{
    e[cont].from=from;
    e[cont].to=to;
    e[cont].w=w;
    e[cont].next=head[from];
    head[from]=cont++;
}
void SPFA(int ss,int d)
{
    for(int i=1;i<=n;i++)dis[d][i]=0x3f3f3f3f;
    dis[d][ss]=0;
    queue<int >s;
    memset(vis,0,sizeof(vis));
    vis[ss]=1;
    s.push(ss);
    while(!s.empty())
    {
        int u=s.front();
        s.pop();
        vis[u]=0;
        for(int i=head[u];i!=-1;i=e[i].next)
        {
            int v=e[i].to;
            int w=e[i].w;
            if(dis[d][v]>dis[d][u]+w)
            {
                dis[d][v]=dis[d][u]+w;
                if(vis[v]==0)
                {
                    s.push(v);
                    vis[v]=1;
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        cont=0;
        memset(head,-1,sizeof(head));
        for(int i=0;i<m;i++)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            add(x,y,w);
            add(y,x,w);
        }
        SPFA(1,0);
        SPFA(n,1);
        int minn;
        int ciminn;
        minn=ciminn=0x3f3f3f3f;
        for(int i=0;i<cont;i++)
        {
            int tmp;
            int w=e[i].w+dis[0][e[i].from]+dis[1][e[i].to];
            if(w<minn)
            {
                tmp=minn;
                minn=w;
                w=tmp;
            }
            if(w<ciminn&&w!=minn)
            {
                ciminn=min(ciminn,w);
            }
        }
        printf("%d\n",ciminn);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值