TOJ 1923.Tanning Salon

题目链接:http://acm.tju.edu.cn/toj/showp1923.html



1923.    Tanning Salon
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1299    Accepted Runs: 749



Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input
2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0
Sample Output
All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.



Source: Mid-Central USA 2002
Submit   List    Runs   Forum   Statistics


水题,自己也比较水,调了好久测试用例才调通。。。

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int main(){
	int n;
	string a;
	char room[21];
	while(~scanf("%d",&n),n){
		int leaveNumber=0;
		int rooms=n;
		string b="#";
		memset(room,'#',sizeof(room));
		cin>>a;
		for(int i=0;i<a.length();i++){
			int tmp=1;
			for(int j=0;j<b.length();j++)
				if(b[j]==a[i])
					{tmp=0;break;}
			if(!tmp)
				continue; 
			if(!rooms){
				for(int j=0;j<n;j++)
					if(a[i]==room[j]){
						rooms++;
						room[j]='#';
						tmp=0;
						break;
				}
				if(tmp){
					b+=a[i];
					leaveNumber++;
					continue;
				}
			}
			for(int j=0;j<n;j++)
				if(a[i]==room[j]){
					rooms++;
					room[j]='#';
					tmp=0;
					break;
				}
			if(tmp){
				rooms--;
				for(int j=0;j<n;j++)
					if(room[j]=='#'){
						room[j]=a[i];
						//cout<<room<<endl;
						break;
					}
			}
				
		}
		if(!leaveNumber)
			printf("All customers tanned successfully.\n");
		else
			printf("%d customer(s) walked away.\n",leaveNumber);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值