poj1250 Tanning Salon

 

Tanning Salon

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8467 Accepted: 4527

 

Description

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning. 

Input

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon. 

Output

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below. 

Sample Input

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.

 

题意:有n个位置,每个字母第一次出现代表客人的进来,第二次出现代表离开(每个字母都一定出现两次) 
统计流失了几个客户  

 

 

//
// Created by Admin on 2017/3/5 
// 
#include<cstdio>
#include<cstring>
int main(){
	int n;
	while(scanf("%d",&n),n){
		int ans=0,cus[28],mark[28];  //cus:记录客户的状态;mark:用于判断是否为同一客户 
		char temp[10000];
		memset(cus,0,sizeof(cus));  //初始化客户都未进来 
		memset(mark,0,sizeof(mark));  
		scanf("%s",temp);
		for(int i=0;i<strlen(temp);i++){  //判断每个客户要进入还是离开 
			if(cus[temp[i]-'A']==0){  //客户状态如果为0,即是要进入 
				if(n>0){  //如果还有位置 
					cus[temp[i]-'A']=1;  //则客户进入,状态置1,表示客户在店内 
					n--;  //计算剩余位置 
				}
				else{  //如果没有位置,则流失客户 
					mark[temp[i]-'A']++;  
					if(mark[temp[i]-'A']==1)ans++; //如果该客户已经算过,则不再重复计入总数 
				} 
			}
			else n++;  //如果客户状态为1,则客户离开,计算剩余位置 
		}
		if(ans)printf("%d customer(s) walked away.\n",ans);
		else printf("All customers tanned successfully.\n");
	}
	return 0;
}

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值