HDU 1162 Eddy's picture Kruskal算法

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4361    Accepted Submission(s): 2151


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
  
  
3.41
 

Author
eddy
 

Recommend
JGShining
 
 
Kruskal算法:思想是对边作贪心处理,每次找最短边,直到找到n-1条边构成最小生成树。定义结构体包括边的权值,有向边的始点和终点,重载小于号对边排序。
 
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;

//const int INF=0x3fffffff;
int father[1100];
int save[1100];

struct Point
{
	double x,y;
}d[1100000];

struct Edge
{
	int s,e;
	double value;
	const bool operator<(const struct Edge &old)const
	{
		return value<old.value;
	}
}edge[110000];

int FindRoot (int a )
{	
	int k=0;
	while ( a != father[a] )
	{
		save[k++] = a;
		a = father[a];
	}
	for(int i=0;i<k;i++)
		father[ save[i] ] = a;	
	return a;
}

void Union(int x,int y)
{
	x=FindRoot(x);
	y=FindRoot(y);
	if(x!=y)
		father[x]=y;
}

void init()
{
	for(int i=0;i<=1000;i++)
		father[i]=i;
}

float Kruskal(int N)
{
	//int m=(n*(n-1)/2);
	sort(edge,edge+N);
	int i,a,b;
	double sum=0.0;
	for(i=0;i<N;i++)   //可用cnt记录找到的边数,cnt>n-1退出循环,优化
	{
		a=edge[i].s;
		b=edge[i].e;
		if(FindRoot(a)!=FindRoot(b)) //如果一条边的始点和终点已在一个集合,说明这两个点已贪心在子树中,不在作处理
		{
			Union(a,b);
			sum+=edge[i].value;
		}
	}
	return sum;
}

int main()
{
	int n,m;
	int i,j;
	while(scanf("%d",&n)!=EOF)
	{
		init();
		for(i=1;i<=n;i++)
			scanf("%lf%lf",&d[i].x,&d[i].y);
		int k=0;
		for(i=1;i<n;i++)
		{
			for(j=i+1;j<=n;j++)
			{	
				edge[k].s=i;
				edge[k].e=j;
				edge[k].value=sqrt( (d[i].x-d[j].x)*(d[i].x-d[j].x) + (d[i].y-d[j].y)*(d[i].y-d[j].y) );
				k++;
			}
		}
		printf("%.2lf\n",Kruskal(k));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值