HDU 1690 Bus System

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4254    Accepted Submission(s): 1074


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
  
  
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
  
  
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 

Source
 

Recommend
wangye
 
题意:输入站号,计算cost。题目最后是问第几个站到第几个站的最少花费,不是问哪个站号到哪个站号。站号只是用来计算cost,map从1到n构图即可。
 
#include<stdio.h>
#include<math.h>


const __int64 INF=0x3ffffffffff;//至少大于10亿

__int64 map[111][111];

void floyd(int n)
{
    int k,i,j;
    for(k=1;k<=n;k++)
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                if(map[i][k]+map[k][j]<map[i][j])
                {
                    map[i][j]=map[i][k]+map[k][j];
                //    map[j][i]=map[i][j];
                }
}

main()
{
    int cases;
    __int64 l1,l2,l3,l4,c1,c2,c3,c4;
    int n,m,i,j;
    __int64 tmp;
    __int64 ss,ee,s,e;
    //int rec[111];
    __int64 sta[101];
    int cnt=1;
    scanf("%d",&cases);
    while(cases--)
    {
        scanf("%I64d%I64d%I64d%I64d%I64d%I64d%I64d%I64d",&l1,&l2,&l3,&l4,&c1,&c2,&c3,&c4);
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
        {
            scanf("%I64d",&sta[i]);
        }
        /*for(i=1;i<=100;i++)
            for(j=1;j<=100;j++)
            {
                if(i!=j)
                    map[i][j]=INF;
                else
                    map[i][j]=0;
            }*/
        for(i=1;i<n;i++)
            for(j=1;j<=n;j++)
            {
                tmp=abs(sta[i]-sta[j]);
                if(i==j) map[i][j]=0;
                if(tmp>0 &&tmp<=l1)
                    map[i][j]=map[j][i]=c1;
                if(tmp>l1 && tmp<=l2)
                    map[i][j]=map[j][i]=c2;
                if(tmp>l2 && tmp<=l3)
                    map[i][j]=map[j][i]=c3;
                if(tmp>l3 && tmp<=l4)
                    map[i][j]=map[j][i]=c4;
                if(tmp>l4)
                    map[i][j]=map[j][i]=INF;
            }
        floyd(n);
        printf("Case %d:\n",cnt);
        while(m--)
        {
            scanf("%I64d%I64d",&ss,&ee);
            /*for(i=1;i<=n;i++)
            {
                if(sta[i]==ss)
                {s=i;break;}
                else
                    s=-1;
            }
            for(i=1;i<=n;i++)
            {
                if(sta[i]==ee)
                {e=i;break;}
                else
                    e=-1;
            }*/
            if(map[ss][ee]>=INF)
                printf("Station %I64d and station %I64d are not attainable.\n",ss,ee);
            else
                printf("The minimum cost between station %I64d and station %I64d is %I64d.\n",ss,ee,map[ss][ee]);
            
        }
        cnt++;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值