HDU1069 Monkey and Banana DP非连续单调递增序列的最大和的变种


Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11537    Accepted Submission(s): 6028


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
 

题意:堆箱子,要长宽都小于底座的才能放上面,给你30种箱子告诉他们的长宽高(每种有无数个),问最高能堆多少。

思路:每种箱子都有6种状态,把这六种状态都写出来,最多180种,这180种就不会被重复使用了,因为长宽要strictly小于底座才能堆上去。然后把这180种排个序,按照长和宽排序,然后就转化成了求非连续的单调递增序列的最大和。用dp就行了,我的dp[i]代表以i为起点的最大和。从右向左更新就行,更新时要求两个元素的底座前者能包含后者。




#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <iomanip>
#include <time.h>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff;
const int MAX_N=10000;

int N;
int a,b,c;

struct node{
    int x,y,h;
    node(){};
    node(int X,int Y,int H){
        x=X;
        y=Y;
        h=H;
    };
    friend bool operator<(const node &q,const node &w){
        if(q.x>w.x)return 1;
        if(q.x==w.x)return q.y>w.y;
        return 0;
    }
};

node A[200];

int dp[200];
int main(){
    int t=1;
    while(cin>>N&&N!=0){
        for(int i=0;i<N;i++){
            scanf("%d%d%d",&a,&b,&c);
            A[i*6]=node(a,b,c);
            A[i*6+1]=node(b,a,c);
            A[i*6+2]=node(c,a,b);
            A[i*6+3]=node(c,b,a);
            A[i*6+4]=node(a,c,b);
            A[i*6+5]=node(b,c,a);

        }

        sort(A,A+6*N);
//        for(int i=0;i<6*N;i++){
//            cout<<A[i].x<<" "<<A[i].y<<" "<<A[i].h<<endl;
//        }
        memset(dp,0,sizeof(dp));
        int ans=-1;
        N=6*N;
        for(int i=N-1;i>=0;i--){
            dp[i]=A[i].h;
            for(int j=i+1;j<N;j++){
                if(A[j].x<A[i].x&&A[j].y<A[i].y){
                    dp[i]=max(dp[i],dp[j]+A[i].h);
                }
            }
            ans=max(ans,dp[i]);
        }
        printf("Case %d: maximum height = %d\n",t++,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值