HDU 5475 La Vie en rose(暴力 2016 Multi-University Training Contest 2 )

227 篇文章 0 订阅
39 篇文章 0 订阅

传送门
Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string p=p1p2…pm. So, he wants to generate as many as possible pattern strings from p using the following method:

  1. select some indices i1,i2,…,ik such that 1≤i1< i2<…< ik<|p| and |ij−ij+1|>1 for all 1≤j< k.
  2. swap pij and pij+1 for all 1≤j≤k.

Now, for a given a string s=s1s2…sn, Professor Zhang wants to find all occurrences of all the generated patterns in s.

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n≤105,1≤m≤min{5000,n}) – the length of s and p.

The second line contains the string s and the third line contains the string p. Both the strings consist of only lowercase English letters.

Output
For each test case, output a binary string of length n. The i-th character is “1” if and only if the substring sisi+1…si+m−1 is one of the generated patterns.

Sample Input
3
4 1
abac
a
4 2
aaaa
aa
9 3
abcbacacb
abc

Sample Output
1010
1110
100100100

题目大意:
这个题目主要是读懂题意,给定两个串个,让其匹配,满足两个条件选择的下标的位置 > 1,然后可以交换两个注意这里 swap pij and pij+1 for all 1≤j≤k.交换的是两个相邻的下标,读懂题意很重要,最好是自己在好好的读一遍。

解题思路:
正解是DP(不是很会,暴力的据说比正解还快),因为交换的是相邻的所以,我们就考虑两种情况就行了,要么交换完之后的相邻两个相等,要么本身就相等,只有这样才能使匹配子串,具体看我的代码。
My Code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
const int MAXN = 1e5+5;
int ans[MAXN];
char s[MAXN], p[MAXN];
int main()
{
    int T;
    int n, m ,i, j, k;
    scanf("%d",&T);
    while(T--)
    {
        memset(ans, 0, sizeof(ans));
        scanf("%d%d",&n,&m);
        scanf("%s",s);
        scanf("%s",p);
        k = 0;
        for(i=0; i<n; i++)
        {
            k = i;
            for(j=0; j<m; j++)
            {
                if(p[j] == s[k])
                   k++;
                else if(p[j]==s[k+1]&&p[j+1]==s[k])
                {
                    k += 2;
                    j++;
                }
                else
                    break;
            }
            if(j >= m)
                ans[i] = 1;
        }
        for(int i=0; i<n; i++)
            printf("%d",ans[i]);
        puts("");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值