HDU 5996 dingyeye loves stone(阶梯尼姆博弈)——BestCoder Round #90

227 篇文章 0 订阅
23 篇文章 0 订阅

dingyeye loves stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 121    Accepted Submission(s): 72


Problem Description
dingyeye loves play stone game with you.

dingyeye has an n -point tree.The nodes are numbered from 0 to n1 ,while the root is numbered 0 .Initially,there are a[i] stones on the i -th node.The game is in turns.When one move,he can choose a node and move some(this number cannot be 0) of the stones on it to its father.One loses the game if he can’t do anything when he moves.

You always move first.You want to know whether you can win the game if you play optimally.
 

Input
In the first line, there is an integer T indicating the number of test cases.

In each test case,the first line contains one integer n refers to the number of nodes.

The next line contains n1 integers fa[1]fa[n1] ,which describe the father of nodes 1n1 (node 0 is the root).It is guaranteed that 0fa[i]<i.

The next line contains n integers a[0]a[n1],which describe the initial stones on each nodes.It is guaranteed that 0a[i]<134217728 .

1T100 , 1n100000 .

It is guaranteed that there is at most 7 test cases such that n>100.
 

Output
For each test case output one line.If you can win the game,print "win".Ohterwise,print "lose".
 

Sample Input
  
  
2
2
0
1000 1
4
0 1 0
2 3 3 3
 

Sample Output
  
  
win
lose

题目大意:
dingyeye喜欢和你玩石子游戏。dingyeye有一棵 n 个节点的有根树,节点编号为0 n1 ,根为 0 号节点。游戏开始时,第i个节点上有 a[i] 个石子。两位玩家轮流操作,每次操作玩家可以选择一个节点,并将该节点上的一些石子(个数不能为 0 )移动到它的父亲节点上去。如果轮到某位玩家时,该玩家没有任何合法的操作可以执行,则判负。你在游戏中执先手,你想知道当前局面你能否必胜。

解题思路:

设根节点的深度为0,将所有深度为奇数的节点的石子数目 xor 起来,则先手必胜当且仅当这个 xor 和不为 0 。 证明同阶梯博弈。对于偶深度的点上的石子,若对手移动它们,则可模仿操作;对于奇深度上的石子,移动一次即进入偶深度的点。 时空复杂度O(n)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
using namespace std;
const int MAXN = 1e5+5;
typedef long long LL;
LL a[MAXN];
vector<LL>vec[MAXN];
int n;
void Init(){
    for(int i=0; i<=n; i++)
        vec[i].clear();
}
LL ok = 0;
void dfs(int u, int dep)
{
    if(dep & 1)
        ok ^= a[u];
    for(int i=0; i<vec[u].size(); i++)
    {
        LL k = vec[u][i];
        dfs(k,dep+1);
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        Init();
        for(int i=1; i<n; i++){
            LL x;
            scanf("%I64d",&x);
            vec[x].push_back(i);
        }
        for(int i=0; i<n; i++)
            scanf("%I64d",&a[i]);
        ok = 0;
        dfs(0, 0);
        if(ok)
            puts("win");
        else
            puts("lose");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值