hdu 1907(尼姆博弈)

12 篇文章 0 订阅

原题:http://acm.hdu.edu.cn/showproblem.php?pid=1907

尼姆博弈(Nimm Game):简单地说,就是有n堆若干个东西,两个人轮流从某一堆取任意多的东西,规定每次至少取一个,多者不限,最后取光者得胜。

以下内容有转载部分:

例子:

当n=3时,如果是面对(0,0,0)那就是谁输了,这也叫做奇异局势那么再从下往上推也就是说面对(0,a,b)(a,b不等于0)时也是输的,(0,a,b)也是奇异局势,同样(1,a,b)(这里a,b不相等)也是奇异局势。

       计算机算法里面有一种叫做按位模2加,也叫做异或的运算,用符号^表示这种运算,先看(1,2,3)的异或的结果:
  1 =二进制01 
  2 =二进制10 
  3 =二进制11 ^
  ——————— 
  0 =二进制00  
  对于奇异局势(0,n,n)也一样,结果也是0。
  任何奇异局势(a,b,c)都有a^b^c =0。

异或简单口诀(这指的是二进制里的相同位置上的):相同为0,不同为1


所以对于取光者胜的题目也就是把每堆数量求异或a1^a2^...^ai'^...^an,如果结果为零则先手必输,否则必赢。

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2582    Accepted Submission(s): 1403


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input
  
  
2 3 3 5 1 1 1
 

Sample Output
  
  
John Brother
 

Source

题意:有n中不同颜色的糖,每种的数量为a个,John和Brother轮流吃,每次可以吃任意多个(至少一个)相同颜色的糖。最后一个吃完的输。
AC代码如下:

#include <stdio.h>
/*
author:YangSir
time:2014/5/3
*/
int main()
{
	int n,i,t,a,sum,flag;
	scanf("%d",&t);
	while(t--)
	{
		sum=flag=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);
			sum^=a;
			if(a>1)
				flag=1;//判断是否都为1
		}
		if((sum==0&&flag)||(sum&&flag==0))
			//sum==0&&flag是能化成sum&&flag==0这个形式
			//sum&&flag==0相当于有奇数个堆,每堆个数都为1
			printf("Brother\n");
		else
			printf("John\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值