Red and Black 深搜


B - Red and Black
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
题意:就是数一下一个@所在的位置可以走多少步的问题。
思路:找到@的地方进行深搜有四个方向,没有剪枝
AC代码:
#include<iostream>
#include<cstdio>
using namespace std;
char map[20][20];
int b[4]={0,1,-1,0};
int bb[4]={1,0,0,-1};
int r,c;
int sx,sy;
int tol;
int ok(int x,int y){
    if(x<0||y<0||x>=r||y>=c||map[x][y]=='#')return 0;
    return 1;
}
void dfs(int x,int y){
    for(int i=0;i<4;i++){
        map[x][y]='#';
        if(ok(x+b[i],y+bb[i])){
            tol++;
            dfs(x+b[i],y+bb[i]);
        }
    }
}
int main (){
    while(scanf("%d%d",&c,&r)!=EOF&&r!=0&&c!=0){
        getchar();
        for(int i=0;i<r;++i){
                for(int j=0;j<c;j++){
                   scanf("%c",&map[i][j]);//记住此处gets()是不行的,可能输入空格
                   if(map[i][j]=='@'){
                    sx=i;
                    sy=j;
                   }
                }
        if(i<r-1){getchar();}
        }
        tol=1;
        dfs(sx,sy);
        printf("%d\n",tol);
    }
    return 0;
}
这倒以前做过的,看见还是发现有点陌生,长时间不敲就忘了怎么弄,好好强化。。
 
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值