1004 Toxophily

Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.<br>We all like toxophily.<br><br>Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?<br><br>Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. <br>
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.<br>Technical Specification<br><br>1. T ≤ 100.<br>2. 0 ≤ x, y, v ≤ 10000. <br>
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.<br>Output "-1", if there's no possible answer.<br><br>Please use radian as unit. <br>
 

Sample Input
  
  
3<br>0.222018 23.901887 121.909183<br>39.096669 110.210922 20.270030<br>138.355025 2028.716904 25.079551<br>
 

Sample Output
  
  
1.561582<br>-1<br>-1<br>
 

Source
The 4th Baidu Cup final



#include <iostream>

#include <stdio.h>

#include <math.h>

using namespace std;

int main()

{

    int t;

    doublea,b,c,angle,z;

    doublex,y,v,g = 9.8,T,ans1,ans2;

   scanf("%d",&t);

    while(t--)

    {

       scanf("%lf%lf%lf",&x,&y,&v);

       if(x==0&&y==0)

       printf("0\n");

        elseif(x==0&&y>0)

       printf("90\n");

        else

        {

            a =g*pow(x,2)/(2*pow(v,2));

            b =-x;

            c =y+a;

            T =pow(b,2) - 4*a*c;

           angle = 0;

           if(T<0)

           printf("-1\n");

            else

            {

               ans1 = ((-b)+pow(T,1.0/2))/(2*a);

               ans2 = ((-b)-pow(T,1.0/2))/(2*a);

               if(ans1>=0) angle = atan(ans1);

               if(ans2>=0)

               {

                   z =  atan(ans2);

                   if(z<angle) angle = z;

                   printf("%.6f\n",angle);

               }

               if(ans1<0&&ans2<0)

                   printf("-1\n");

            }

        }

    }

    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值