PAT 1013. Battle Over Cities (25)(孤岛的个数,DFS或者BFS)

题目

1013. Battle Over Cities (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

解题思路

  • 1.谨慎使用vector,会超时!
  • 2.题目大意是敌军占据的城市相连的道路都不能走了,但是要把剩下的所有的城市都用道路连接起来,问至少要修几条路。
  • 3.可以把能够相连的城市当作一个整体,用BFS或者DFS找出来有多少个这样的整体,那么要修的道路的个数就是这个整体的个数减1。

超时代码(慎用vector)

#include<iostream>
#include<cstdio>
#include<string.h>
#include<vector>
#include<deque>
using namespace std;
int n,m,k;
bool isConnect[1001][1001];
bool visited[1001];
int main(int argc, char *argv[])
{
    ios_base::sync_with_stdio(false);
    memset(isConnect,false,sizeof(isConnect));
    memset(visited,false,sizeof(visited));
    cin >> n >> m >> k;

    int w,t;
    for (int i = 0; i < m; ++i) {
        cin >> w >> t;
        isConnect[w][t] = isConnect[t][w] = true;
    }
    //输入要检查的城市
    vector<int> check(k);
    for (int i = 0; i < k; ++i) {
        cin >> check[i];
    }
    for (int i = 0; i < k; ++i) {
        //初始化visited
        memset(visited,false,sizeof(visited));
        //搜索每个城市,看还有多少个城市群
        int cnt_city_group = 0;
        //将check[i]标记为访问那么于这个城市相连的道路就走不通了!!!
        visited[check[i]] = true;
        deque<int> c;
        for (int k = 1; k <= n; ++k) {
            if (!visited[k]) {
                c.push_back(k);
                cnt_city_group++;
                while (!c.empty()) {
                    int topCity = c.front();
                    visited[topCity] = true;
                    c.pop_front();
                    for (int k1 = 1; k1 <= n; ++k1) {
                        if (!visited[k1]&&isConnect[topCity][k1]) {
                            c.push_back(k1);
                        }
                    }
                }
            }
        }
        //还有cnt_city_group个城市群是互相没有道路链接的,则这些至少要修cnt_city_group - 1条道路
        cout << cnt_city_group - 1 << endl;
    }
    return 0;
}

AC代码

#include<iostream>  
#include<string.h>  
using namespace std;  
#include<queue>  
#define  N 1001  
int main()  
{  
    int n,m,k,i,j,t,c1,c2;  
    bool highways[N][N];  
    int concern[N];  
    memset(highways,0,sizeof(highways));  
    memset(concern,0,sizeof(concern));  
    cin>>n;  
    cin>>m;  
    cin>>k;  
    for(i=0;i<m;i++){  
        cin>>c1;  
        cin>>c2;  
        highways[c1][c2]=true;  
        highways[c2][c1]=true;  
    }  
    for(i=0;i<k;i++){  
        cin>>concern[i];  
    }  
    for(i=0;i<k;i++){  
        int visit[N],count,tmp;  
        queue<int> q;  
        memset(visit,0,sizeof(visit));  
        visit[concern[i]]=1;  
        count=0;  
        for(j=1;j<=n;j++){  
            if(visit[j]!=1){  
                queue<int> dq;  
                visit[j]=1;  
                dq.push(j);  
                //对与被占领城市的直接相连的每个城市做BFS  
                while(!dq.empty()){  
                    tmp=dq.front();  
                    dq.pop();  
                    for(t=0;t<=n;t++){  
                        if(highways[tmp][t]!=false&&visit[t]!=1){  
                            dq.push(t);  
                            visit[t]=1;  
                        }  
                    }  
                }  
                /*如果现有节点可以遍历所有了所有点,不需要加边,退出。 
                否则独立“孤岛”+1,通过下一个直接相连节点且未被访问的节点,寻找下一个孤岛*/  
                count++;  
            }  
        }  
        cout<<count-1<<endl;/*需要添加的路,就是连接各个孤岛所需要的最少路径*/  
    }  
    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值