1013. Battle Over Cities (25)-PAT

1013. Battle Over Cities (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
推荐指数:※※
注意:题目中并有指明原来的图是连通的。。
#include<iostream>
#include<string.h>
using namespace std;
#include<queue>
#define  N 1001
int main()
{
	int n,m,k,i,j,t,c1,c2;
	bool highways[N][N];
	int concern[N];
	memset(highways,0,sizeof(highways));
	memset(concern,0,sizeof(concern));
	cin>>n;
	cin>>m;
	cin>>k;
	for(i=0;i<m;i++){
		cin>>c1;
		cin>>c2;
		highways[c1][c2]=true;
		highways[c2][c1]=true;
	}
	for(i=0;i<k;i++){
		cin>>concern[i];
	}
	for(i=0;i<k;i++){
		int visit[N],count,tmp;
		queue<int> q;
		memset(visit,0,sizeof(visit));
		visit[concern[i]]=1;
		count=0;
		for(j=1;j<=n;j++){
			if(visit[j]!=1){
				queue<int> dq;
				visit[j]=1;
				dq.push(j);
				//对与被占领城市的直接相连的每个城市做BFS
				while(!dq.empty()){
					tmp=dq.front();
					dq.pop();
					for(t=0;t<=n;t++){
						if(highways[tmp][t]!=false&&visit[t]!=1){
							dq.push(t);
							visit[t]=1;
						}
					}
				}
				/*如果现有节点可以遍历所有了所有点,不需要加边,退出。
				否则独立“孤岛”+1,通过下一个直接相连节点且未被访问的节点,寻找下一个孤岛*/
				count++;
			}
		}
		cout<<count-1<<endl;/*需要添加的路,就是连接各个孤岛所需要的最少路径*/
	}
	return 0;
}


 
 
九度题目1526:朋友圈和这个类似
  
  
题目描述:

假如已知有n个人和m对好友关系(存于数字r)。如果两个人是直接或间接的好友(好友的好友的好友...),则认为他们属于同一个朋友圈,请写程序求出这n个人里一共有多少个朋友圈。 假如:n = 5 , m = 3 , r = {{1 , 2} , {2 , 3} , {4 , 5}},表示有5个人,1和2是好友,2和3是好友,4和5是好友,则1、2、3属于一个朋友圈,4、5属于另一个朋友圈,结果为2个朋友圈。

输入:

输入包含多个测试用例,每个测试用例的第一行包含两个正整数 n、m,1=<n,m<=100000。接下来有m行,每行分别输入两个人的编号f,t(1=<f,t<=n),表示f和t是好友。 当n为0时,输入结束,该用例不被处理。

输出:

对应每个测试用例,输出在这n个人里一共有多少个朋友圈。

样例输入:
5 3
1 2
2 3
4 5
3 3
1 2
1 3
2 3
0
样例输出:
2
1
#include<iostream>
#include<string.h>
#include<vector>
using namespace std;
#include<queue>
#define  N 100000
int main()
{
	int n,m,i,j,t,c1,c2,k;
	cin>>n;
	while(n>0){
		vector<int> highways[N];
		cin>>m;
		for(i=0;i<m;i++){
			cin>>c1;
			cin>>c2;
			highways[c1].push_back(c2);
			highways[c2].push_back(c1);
		}
		int visit[N],count,tmp;
		queue<int> q;
		memset(visit,0,sizeof(visit));
		count=0;
		for(j=1;j<=n;j++){
			if(visit[j]!=1){
				queue<int> dq;
				visit[j]=1;
				dq.push(j);
				while(!dq.empty()){
					tmp=dq.front();
					dq.pop();
					//for(t=0;t<=n;t++){
					for(int i=0;i<highways[tmp].size();i++){
						t=highways[tmp][i];
						if(visit[t]!=1){
							dq.push(t);
							visit[t]=1;
						}
					}
				}
				/*Èç¹ûÏÖÓнڵã¿ÉÒÔ±éÀúËùÓÐÁËËùÓе㣬²»ÐèÒª¼Ó±ß£¬Í˳ö¡£
				·ñÔò¶ÀÁ¢¡°¹Âµº¡±+1£¬Í¨¹ýÏÂÒ»¸öÖ±½ÓÏàÁ¬½ÚµãÇÒδ±»·ÃÎʵĽڵ㣬ѰÕÒÏÂÒ»¸ö¹Âµº*/
				count++;
			}
		}
		cout<<count<<endl;/*ÐèÒªÌí¼ÓµÄ·£¬¾ÍÊÇÁ¬½Ó¸÷¸ö¹ÂµºËùÐèÒªµÄ×îÉÙ·¾¶*/
		cin>>n;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值