POJ-3041 Asteroids(二分图最小定点覆盖)

原题链接

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19789 Accepted: 10742

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

asteroids在(x,y)处,则x行和y列连一条边,用二分图求最小定点覆盖

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#define maxn 505
using namespace std;

vector<int> v[maxn];
int vis[maxn], g[maxn];
bool dfs(int i){
	
	for(int j = 0; j < v[i].size(); j++){
		int h = v[i][j];
		if(vis[h] == 0){
			vis[h] = 1;
			if(g[h] == 0 || dfs(g[h])){
				g[h] = i;
			    return true;
			}
		}
	}
	return false;
}
int main(){
	
//	freopen("in.txt", "r", stdin);
	int n, k;
	
	while(scanf("%d%d", &n, &k) == 2){
		
		int a, b;
		for(int i = 1; i <= n; i++)
		  v[i].clear();
		for(int i = 1; i <= k; i++){
			scanf("%d%d", &a, &b);
			v[a].push_back(b);
		}
		memset(g, 0, sizeof(g));
		int ans = 0;
		for(int i = 1; i <= n; i++){
		    memset(vis, 0, sizeof(vis));
			if(v[i].size() && dfs(i))
			  ans++;
		}
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值