POJ 1775 (ZOJ 2358) Sum of Factorials

324 篇文章 134 订阅
18 篇文章 0 订阅

Description

John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics,meteorology, science, computers, and game theory. He was noted for a phenomenal memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest. His Ph.D. dissertation on set theory was an important contribution to the subject. At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established him as a mathematician of unusual depth. His Mathematical Foundations of Quantum Mechanics (1932) built a solid framework for the new scientific discipline. During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944).
There are some numbers which can be expressed by the sum of factorials. For example 9,9=1!+2!+3! Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell him whether or not the number can be expressed by the sum of some factorials.
Well, it’s just a piece of cake. For a given n, you’ll check if there are some xi, and let n equal to Σ1<=i<=txi!. (t >=1 1, xi >= 0, xi = xj iff. i = j). If the answer is yes, say “YES”; otherwise, print out “NO”.
Input

You will get several non-negative integer n (n <= 1,000,000) from input file. Each one is in a line by itself.
The input is terminated by a line with a negative integer.
Output

For each n, you should print exactly one word (“YES” or “NO”) in a single line. No extra spaces are allowed.
Sample Input

9
-1
Sample Output

YES

注意:0的阶乘是1;(输入0,输出NO)
不是输入-1结束,而是输入负数结束程序;
题目要求不是连续阶乘和;
例如:4=0!+1!+2!=1+1+2
输出 YES;
7=3!+1!;
输出 YES;

我这里的思路是:
从不大于n的最大数开始减,如果能减到n为0,输出YES,否则
输出NO。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int a[10];
void df(){
   for(int i=1;i<10;i++){
     a[i]=i*a[i-1];
   }
}
int main()
{
    a[0]=1;
    df();
//    for(int i=0;i<10;i++){
//        printf("%d\n",a[i]);
//    }
    int n;
    int sum;
    while(scanf("%d",&n)==1&&n>=0){
            sum=n;
            if(n==0){
                printf("NO\n");
                continue;
            }
            int flag=0;
        for(int i=9;i>=0;i--){
            if(a[i]<=sum){
                sum=sum-a[i];
               // printf("i=%d,%d\n",i,a[i]);
            }
        if(sum==0){
            printf("YES\n");
            flag=1;
            break;
        }
        }
        if(flag==0)
        printf("NO\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

谙忆

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值