hdu 2923 floyd+map容器

Einbahnstrasse

TimeLimit: 2000/1000 MS (Java/Others)    Memory Limit:32768/32768 K (Java/Others)
Total Submission(s): 3079    Accepted Submission(s): 960

Problem Description

Einbahnstra e(German for a one-way street) is a street on which vehicles should only move inone direction. One reason for having one-way streets is to facilitate asmoother flow of traffic through crowded areas. This is useful in city centers,especially old cities like Cairo and Damascus. Careful planning guarantees thatyou can get to any location starting from any point. Nevertheless, drivers mustcarefully plan their route in order to avoid prolonging their trip due toone-way streets. Experienced drivers know that there are multiple paths totravel between any two locations. Not only that, there might be multiple roadsbetween the same two locations. Knowing the shortest way between any twolocations is a must! This is even more important when driving vehicles that arehard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number oftowing trucks parked at the company's garage. A tow-truck lifts the front orback wheels of a broken car in order to pull it straight back to the company'sgarage. You receive calls from various parts of the city about broken cars thatneed to be towed. The cars have to be towed in the same order as you receivethe calls. Your job is to advise the tow-truck drivers regarding the shortestway in order to collect all broken cars back in to the company's garage. At theend of the day, you have to report to the management the total distancetraveled by the trucks.

 

 

Input

Your program will be tested on one ormore test cases. The first line of each test case specifies three numbers (N ,C , and R ) separated by one or more spaces. The city has N locations withdistinct names, including the company's garage. C is the number of broken cars.R is the number of roads in the city. Note that 0 < N < 100 , 0<=C< 1000 , and R < 10000 . The second line is made of C + 1 words, thefirst being the location of the company's garage, and the rest being thelocations of the broken cars. A location is a word made of 10 letters or less.Letter case is significant. After the second line, there will be exactly Rlines, each describing a road. A road is described using one of these threeformats:


A -v -> B
A <-v - B
A <-v -> B


A and B are names of two different locations, while v is a positive integer(not exceeding 1000) denoting the length of the road. The first formatspecifies a one-way street from location A to B , the second specifies aone-way street from B to A , while the last specifies a two-way street betweenthem. A , ``the arrow", and B are separated by one or more spaces. The endof the test cases is specified with a line having three zeros (for N , C , andR .)

The test case in the example below is the same as the one in the figure.

 

 

Output

For each test case, print the totaldistance traveled using the following format:


k . V


Where k is test case number (starting at 1,) is a space, and V is the result.

 

 

Sample Input

42 5

NewTroyMidvale Metrodale

NewTroy   <-20-> Midvale

Midvale   --50-> Bakerline

NewTroy    <-5-- Bakerline

Metrodale<-30-> NewTroy

Metrodale  --5-> Bakerline

00 0

 

 

Sample Output

1.80

 

 

Source

2008ANARC

 

 

分析:从起点到某地,然后在倒过来   求最短路的和。

重点是一个地方可能去多次,所以要对要去的地方进行遍历。

同样的用map容器  构造一个有向图  就清楚了

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#define INF 0x3f3f3f3f
#define MAX 1000
using namespace std;
int vis[MAX],dis[MAX];
int map1[MAX][MAX];
char rr[1001][100];
int n,m,C;
void floyd()
{
    for(int k = 1; k <= n; k++)
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                if(map1[i][j] > map1[i][k]+map1[k][j])
                    map1[i][j] = map1[i][k]+map1[k][j];

}
int main()
{
    int case1 = 1;
    while(~scanf("%d%d%d",&n,&C,&m))
    {
        if(n==0&&C==0&&m==0)
            break;
        map<string,int>s;
        int ans = 1;
        s.clear();
        for(int i = 0; i <= C; i++)
        {
            scanf("%s",rr[i]);
            if(rr[i]==0)
                s[rr[i]] = ans++;
        }
        for(int i = 0; i < 110; i++)
        {
            for(int j = 0; j < 110; j++)
                map1[i][j] = INF;
            map1[i][i] = 0;
        }
        char p[31],q[31];
        char a[31];
        for(int i = 0; i < m; i++)
        {
            scanf("%s%s%s",p,a,q);
            if(!s[p]) s[p] = ans++;
            if(!s[q]) s[q] = ans++;
            int len = strlen(a);
            int value = 0,flag = 1;
            for(int j = len - 3; j > 1; j--)
            {
                value+=(a[j] - 48)*flag;
                flag*=10;
            }
            if(map1[s[p]][s[q]] > value&&a[0] == '<')
                map1[s[p]][s[q]] = value;
            if(map1[s[q]][s[p]] > value&&a[len-1] == '>')
                map1[s[q]][s[p]] = value;
        }
        /**for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < n; j++)
                printf("%d ",map1[i][j]);
            printf("\n");
        }*/
        printf("%d. ",case1++);
        floyd();
        int sum = 0;
        for(int i = 1; i <= C; i++)
        {
            sum+=map1[s[rr[0]]][s[rr[i]]] + map1[s[rr[i]]][s[rr[0]]];
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值