POJ 2406:Power Strings

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41252 Accepted: 17152

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:

给出的一个字符串某个字串链接N次得出的,求最大N;


思想:

KMP匹配算法之next[];模式串结尾指针回溯最小移动次数即最小字串长度,N=s.length%(s.length-next[s.length]);


#include <stdio.h>
#include <string.h>
char s[1000005];
int num[1000005];
int main()
{
    while(scanf("%s",s),s[0]!='.')
    {
        int j=-1;
        num[0]=-1;
        int n=strlen(s);
        for(int i=0; i<n;)
        {
            if(j==-1||s[i]==s[j])num[++i]=++j;
            else j=num[j];
        }
        if(n%(n-num[n])==0)
            printf("%d\n",n/(n-num[n]));
        else printf("1\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值