POJ 2406

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 37793 Accepted: 15643

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3
        这道题是很典型的kmp算法的应用,因为如果不使用kmp算法采用别的搜索方法,超时几乎是妥妥的。这道题要求相对简单,只需要求出next数组就可以得出答案,next数组是前缀数组,使得无论是检索还是其他的用途都很方便(尽管我还不是太理解其中的原理,但是画下图感觉还是很神奇的),题目只是要求出现的循环字段的最大数目,所以最后直接用next的现成值计算就可以了。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int nxt[1000010];
char a[1000010];
int N;
void getnxt(){
	int j,k;
	j=0;k=-1;nxt[0]=-1;
	while(j<N){
		if(k==-1||a[j]==a[k]){
			nxt[++j]=++k;
		}else{
			k=nxt[k];
		}
	}
}//得出next数组(我习惯设成nxt,next有时会报错)

int main(){
	while(scanf("%s",a)!=EOF){
	   if(a[0]=='.') break;
	   N=strlen(a);
	   
	   getnxt();
	   if(N%(N-nxt[N])==0) printf("%d\n",N/(N-nxt[N]));//即循环字段在总字段中出现的次数,如果是整数则找到了,否则说明不存在循环字段
	   else
	   printf("1\n");	   	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值