动态规划 POJ - 2533 Longest Ordered Subsequence(最长递增子序列)

 题目:

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

思路:

动态规划的类型有很多种,其中两种常见解法:
    ①构造的解就是原问题的子问题的解,当规模和问题规模一样大时,解就直接得出。如最长公共子序列等
    ②构造的解不是原问题的子问题的解,但是可以经过结算得到最终解。如最大字段和、最长递增子序列等。
          

本题属于第二种情况:a[]是输入的数据。构造b[j]的值是以a[j]为结尾的最长递增子序列的长度;

    

代码:

#include<iostream>
#include<algorithm>
using namespace std;

int a[1000], b[1000];
int main() {
	int N; cin >> N;
	for (int i = 0; i < N; i++) cin >> a[i];
	memset(b, 0, sizeof(b));
	b[0] = 1;
	for (int i = 1; i < N; i++)
	{
		int max = 0;
		for (int j = i - 1; j >= 0; j--)
			if (a[i] > a[j] && b[j] > max) max = b[j];
		b[i] = max + 1;
	}
	int max = 0;
	for (int i = 0; i < N; i++) max = b[i] > max ? b[i] : max;
	cout << max;
	//cout << b[N - 1];
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值