poj 2533 Longest Ordered Subsequence 最长递增子序列

Longest Ordered SubsequenceTime Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:求一个串的最长递增子序列(严格)

思路:相信大家在学习最长公共子序列的时候,一定也听过最长递增序列,因为这两个问题非常相似,求最长递增子序列的时候,只需要将原始序列进行排序,然后求原始序列和递增序列的最长公共子序列就行了,这道题目要求是严格递增,因此需要对排序后的序列做除重处理。


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define MAXN 1010
using namespace std;

int dp[2][MAXN];

int max(int a,int b)
{
    return a>b?a:b;
}
int lcs(int *str1,int *str2,int len1,int len2)
{
    int i,j,e=0;
    memset(dp,0,sizeof(dp));
    for(i=1;i<=len1;i++)
    {
        e=1-e;
        for(j=1;j<=len2;j++)
        {
            if(str1[i]==str2[j])
            {
                dp[e][j]=dp[1-e][j-1]+1;
            }
            else
            {
                dp[e][j]=max(dp[1-e][j],dp[e][j-1]);
            }
        }
    }
    return dp[e][len2];
}


int main()
{
    int len1,len2,i,j;
    int str1[MAXN],str2[MAXN];
    while(~scanf("%d",&len1))
    {
        for(i=1;i<=len1;i++)
        {
            scanf("%d",&str1[i]);
            str2[i]=str1[i];
        }
        sort(str2+1,str2+len1+1);
        for(i=1,j=2;j<=len1;j++)
        {
            if(str2[j]!=str2[i])
                str2[++i]=str2[j];
        }
        len2=i;
        printf("%d\n",lcs(str1,str2,len1,len2));
    }


    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值