poj-2533 Longest Ordered Subsequence 【最长上升子序列】

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:

求最长上升子序列,序列不一定要连续。

解题思路:

用dp[]记录到达那的最长序列的话,dp[1]=1。从第二个数开始,如果第二个数大于第一个数num[2]>num[1]那么dp[2]=dp[1]+1否则dp[2]=dp[1].

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int main()
{
	int n,i,j,m;
	int a[1010],dp[1010];
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		dp[1]=1;
		for(i=2;i<=n;i++)
		{
			m=0;
			for(j=1;j<i;j++)
			{
				if(a[i]>a[j])
					if(m<dp[j])
						m=dp[j]; 
			} 
			dp[i]=m+1;
		} 
		sort(dp+1,dp+n+1);
		printf("%d\n",dp[n]);	
	}
	return 0;
}

另一种方法:

外层循环i遍历整个数组,内层循环j遍历i之前的数,只要找到j小于i,即A[j] < A[i],便可以+1,写出状态转移方程max(1,d[j]+1) + 1,所以置a[i]初始化为1,每次更新a[i]即可,最后比较每个a[i],最大的即为要求的结果。


代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int main()
{
	int n,i,j,m;
	int a[1010],dp[1010];
	while(scanf("%d",&n)!=EOF)
	{
		m=0;
		memset(a,0,sizeof(a));
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for(i=1;i<=n;i++)
			dp[i]=1; 
		for(i=1;i<=n;i++)
			for(j=1;j<i;j++)
			{
				if(a[i]>a[j])
					dp[i]=max(dp[i],dp[j]+1);
			} 
		for(i=1;i<=n;i++)
			if(dp[i]>m)
				m=dp[i];
		printf("%d\n",m);	
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值