solution of POJ 2376.Cleaning Shifts

14 篇文章 0 订阅

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

Line 1: Two space-separated integers: N and T

Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2


结题思路
题意要求我们给出能够覆盖指定区间的最少的工作人员。
要求1:如果一个工作人员的工作时间区间覆盖越大,选择他会让我们最后的总人数经可能得降低;
要求2:如果一个工作人员的结束时间为end,则下一个工作人员的开始时间必须小于等于end + 1,结束时间必须大于等于end + 1。

程序步骤
第一步、根据开始时间对所有的工作人员进行递增排序,开始时间相同的情况下对结束时间进行递增排序。
第二步、贪心法遍历数组,找到全部小于等于下一个可行的开始时间的工作人员,选择结束时间最晚的工作人员。


具体程序(AC)如下

#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
using namespace std;
struct cow
{
    int start;
    int end;
};
int cmp(cow& a, cow& b)
{
    if(a.start != b.start)
        return a.start < b.start;
    else
        return a.end < b.end;
}
int solve(vector<cow>& cowList, int t)
{
    int index = 0;
    int counter = 0;
    int start;
    int end = 0;
    int len = cowList.size();
    while(end < t)
    {
        start = end + 1;//下一个最晚的开始时间
        for(int i = index; i < len; ++i)
        {
            if(start >= cowList[i].start) 
            {
                if(start <= cowList[i].end && end < cowList[i].end)//结束时间更新条件
                    end = cowList[i].end;
            }
            else
            {
                index = i;//下一次循环开始的索引编号
                break;
            }
        }
        if(start > end)//结束时间未得到更新,说明没有找到合适的工作人员
            return -1;
        else
            ++counter;
    }
    return counter;
}
int main()
{
    int n, t;
    cin>> n >>t;
    vector<cow> cowList(n);
    for(int i = 0; i < n; ++i)
        cin>> cowList[i].start >> cowList[i].end;
    sort(cowList.begin(), cowList.end(), cmp);
    cout<<solve(cowList, t)<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值