solution of POJ:3190.Stall Reservations

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i’s milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4


结题思路
题意要求我们确定至少需要多少个工厂,才能保证所有奶牛能够按时出现在工厂产奶。
要求1:如果两头奶牛的产奶时间出现交集,则不能出现在同一工厂;
要点2:为当前奶牛找到最早能腾出空间的工厂,如果不满足要求,则需要将奶牛安排到新的工厂。

程序步骤
第一步、自动读入奶牛编号,根据奶牛的产奶开始时间进行递增排序。
第二步、用优先队列保存来保存全部的工厂,每次输出最早能腾出空间的工厂。
第三步、根据最早能腾出的时间判断是可以安排奶牛入厂还是安排新工厂。

具体程序(AC)如下

#include <iostream>
#include <algorithm>
#include <vector>
#include <cmath>
#include <limits>
#include <queue>
using namespace std;
struct stall
{
    int no;
    int start;
    // const成员函数不可以修改对象的数据,不管对象是否具有const性质.它在编译时,以是否修改成员数据为依据,进行检查
    stall(int s){start = 0; no = s;}
    bool operator < (const stall& b) const
    {
        return start > b.start;
    }
};
struct cow
{
    int index;
    int begin;
    int end;
    bool operator < (const cow& b) const
    {
        return begin < b.begin;
    }
};
int main()
{
    int n;
    cin>> n;
    vector<cow> cowList(n);
    vector<int> stallNo(n);
    for(int i = 0; i < n; ++i)
    {
        cowList[i].index = i;
        cin>> cowList[i].begin>> cowList[i].end;
    }
    sort(cowList.begin(), cowList.end());
    priority_queue<stall> pq;
    int no = 0;
    pq.push(stall(++no));
    for(int i = 0; i < n; ++i)
    {
        stall tmp = pq.top();
        //cout<<"no: "<< tmp.no<<" end: "<<tmp.start<<endl;
        if(tmp.start < cowList[i].begin)
        {
            pq.pop();
            stallNo[cowList[i].index] = tmp.no;
            tmp.start = cowList[i].end;
            pq.push(tmp);
        }
        else
        {
            stall add(++no);
            stallNo[cowList[i].index] = add.no;
            add.start = cowList[i].end;
            pq.push(add);
        }
    }
    cout<< pq.size()<< endl;
    for(int i = 0; i < n; ++i)
        cout<<stallNo[i]<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值