POJ-3984-迷宫问题(BFS打印路径)

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16009 Accepted: 9551
Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

重点在于如何打印路径
暴力的方法

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
    int x;
    int y;
};
struct edge
{
    int x;
    int y;
    int steap;
    node num[30];
};
int map[5][5];
int dis[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
void BFS()
{
   queue<edge>q;
   edge star;
   star.x=0;
   star.y=0;
   star.steap=1;
   star.num[0].x=0;
   star.num[0].y=0;
   q.push(star);
   while(!q.empty())
   {
       star=q.front();
       q.pop();
       if(star.x==4&&star.y==4)
       {
           for(int i=0;i<star.steap;i++)
               printf("(%d, %d)\n",star.num[i].x,star.num[i].y);
               return;
       }
       for(int i=0;i<4;i++)
       {
           edge end;
           end=star;
           end.x+=dis[i][0];
           end.y+=dis[i][1];
           if(end.x>=0&&end.x<5&&end.y>=0&&end.y<5&&map[end.x][end.y]==0)
           {
               end.num[end.steap].x=end.x;
               end.num[end.steap].y=end.y;
               end.steap++;
               map[end.x][end.y]=1;
               q.push(end);
           }
       }
   }
}
int main()
{
    for(int i=0; i<5; i++)
        for(int j=0; j<5; j++)
            scanf("%d",&map[i][j]);
    BFS();
    return 0;
}

非暴力,可作为模板的方法

#include<iostream>
using namespace std;
int map[5][5];
int dx[4]= {1,-1,0,0};
int dy[4]= {0,0,-1,1};
int front=0,rear=1;
struct node
{
    int x,y,pre;
} q[100];

void print(int i)//输出过程
{
    if(q[i].pre!=-1)
    {
        print(q[i].pre);
        cout<<"("<<q[i].x<<", "<<q[i].y<<")"<<endl;
    }
}
void bfs(int x1,int y1)//广搜
{
    q[front].x=x1;
    q[front].y=y1;
    q[front].pre=-1;
    while(front<rear)//当队列不空
    {
        for(int i=0; i<4; i++) //搜索可达的路径
        {
            int a=dx[i]+q[front].x;
            int b=dy[i]+q[front].y;
            if(a<0||a>=5||b<0||b>=5||map[a][b])//是否在迷宫内,是否可行
                continue;
            else
            {
                map[a][b]=1; //走过的路做标记
                q[rear].x=a;
                q[rear].y=b;
                q[rear].pre=front;
                rear++; //入队
            }
            if(a==4&&b==4) print(front);
        }
        front++;//出队
    }
}

int main()
{
    int i,j;
    for(i=0; i<5; i++)
        for(j=0; j<5; j++)
            cin>>map[i][j];
    cout<<"(0, 0)"<<endl;
    bfs(0, 0);
    cout<<"(4, 4)"<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值