迷宫问题(BFS)

定义一个二维数组:

int maze[5][5]= {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output
左上角到右下角的最短路径,格式如样例所示。

Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:通过bfs得到到达终点的每个途径,使用结构体数组记录每个途径的完整走法,
在得到最短途径后,抽出整条途径,并回朔重现

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <stack>
using namespace std;
typedef pair<int,int> P;
P st,en;
struct proc
{
    int x,y,step;
    proc *pre;
};
const int N=10;
int maze[N][N];
int n;
bool vis[N][N];
int ar[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
queue<proc> r;
void bfs()
{
    queue<proc> p;
    proc t[N*N];
    proc temp;
    temp.x=st.first;
    temp.y=st.second;
    temp.step=0;
    temp.pre=NULL;
    p.push(temp);
    vis[st.first][st.second]=true;
    int cnt=-1;
    while(p.size())
    {
        cnt++;
        t[cnt]=p.front();
        p.pop();
        for(int i=0;i<4;i++)
        {
            temp.x=t[cnt].x+ar[i][0];
            temp.y=t[cnt].y+ar[i][1];
            if(maze[temp.x][temp.y]!=1&&temp.x>=0&& temp.x<5&&temp.y>=0&&temp.y<5&&!vis[temp.x][temp.y])
            {
                temp.pre=&t[cnt];
                temp.step=t[cnt].step+1;
                vis[temp.x][temp.y]=true;
                p.push(temp);
            }
            if(temp.x==en.first && temp.y==en.second)
            {
                while(temp.pre)
                {
                    r.push(temp);
                    temp=*temp.pre;
                }
            }
        }
    }
}
int main()
{
    st.first=0,st.second=0;
    en.first=4,en.second=4;
    for(int i=0;i<5;i++)
        for(int k=0;k<5;k++)
        cin>>maze[i][k];
    bfs();
    stack<proc> pr;
    while(r.size())
    {
        proc temp=r.front();
        pr.push(temp);
        r.pop();
    }
    printf("(0, 0)\n");
    while(pr.size())
    {
        proc temp=pr.top();
        pr.pop();
        printf("(%d, %d)\n",temp.x,temp.y);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值