uva 11636/Hello World!

When you first made the computer to print the sentence “Hello World!”, you felt so happy, not
knowing how complex and interesting the world of programming and algorithm will turn out to be.
Then you did not know anything about loops, so to print 7 lines of “Hello World!”, you just had to
copy and paste some lines. If you were intelligent enough, you could make a code that prints “Hello
World!” 7 times, using just 3 paste commands. Note that we are not interested about the number
of copy commands required. A simple program that prints “Hello World!” is shown in Figure 1. By
copying the single print statement and pasting it we get a program that prints two “Hello World!”
lines. Then copying these two print statements and pasting them, we get a program that prints four
“Hello World!” lines. Then copying three of these four statements and pasting them we can get a
program that prints seven “Hello World!” lines (Figure 4). So three pastes commands are needed in
total and Of course you are not allowed to delete any line after pasting. Given the number of “Hello
World!” lines you need to print, you will have to find out the minimum number of pastes required to
make that program from the origin program shown in Figure 1.
Input
The input file can contain up to 2000 lines of inputs. Each line contains an integer N (0 < N < 10001)
that denotes the number of “Hello World!” lines are required to be printed.
Input is terminated by a line containing a negative integer.
Output
For each line of input except the last one, produce one line of output of the form ‘Case X: Y ’ where
X is the serial of output and Y denotes the minimum number of paste commands required to make a
program that prints N lines of “Hello World!”.
Sample Input
2
10
-1
Sample Output

Case 1: 1

Case 10:4

被n<0就跳出的条件坑了,,,,

<span style="font-family:Arial;">#include <iostream>//找规律,,0 1 2 2 3 3 3 3 4 4 4 4 4 4 4 4 是2的倍数规律变化
#include<stdio.h>
#include<cmath>
using namespace std;
int a[10005];
int main()
{
    int n,T=1;
    for(int i=1;i<=10005;i++)
    {
        double aa=log(i)/log(2);
        int m,bb=((int)(log(i)/log(2)));
        m=bb;
        if(aa>bb) m++;
        a[i]=m;
    }
    while(scanf("%d",&n)!=EOF&&n>0)
    {
        printf("Case %d: %d\n",T++,a[n]);
    }
    return 0;
}
</span>



<span style="font-family:Arial;">#include <iostream>//贪心算法,
#include<stdio.h>
using namespace std;

int main()
{
    int n,T=1;
    while(scanf("%d",&n)!=EOF&&n>0)
    {
        int sum=1,s=n-1,t=0;
        while(sum<n)
        {
            t++;
            if(s>=sum)
            {
                sum+=sum;
            }else
            {
                sum+=s;
            }
        }
        printf("Case %d: %d\n",T++,t);
    }
    return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值