POJ 3191 The Moronic Cowmpouter

Inexperienced in the digital arts, the cows tried to build a calculating engine (yes, it's a cowmpouter) using binary numbers (base 2) but instead built one based on base negative 2! They were quite pleased since numbers expressed in base −2 do not have a sign bit. 

You know number bases have place values that start at 1 (base to the 0 power) and proceed right-to-left to base^1, base^2, and so on. In base −2, the place values are 1, −2, 4, −8, 16, −32, ... (reading from right to left). Thus, counting from 1 goes like this: 1, 110, 111, 100, 101, 11010, 11011, 11000, 11001, and so on. 

Eerily, negative numbers are also represented with 1's and 0's but no sign. Consider counting from −1 downward: 11, 10, 1101, 1100, 1111, and so on. 

Please help the cows convert ordinary decimal integers (range -2,000,000,000..2,000,000,000) to their counterpart representation in base −2.
Input
Line 1: A single integer to be converted to base −2
Output
Line 1: A single integer with no leading zeroes that is the input integer converted to base −2. The value 0 is expressed as 0, with exactly one 0.
Sample Input
-13
Sample Output
110111
Hint
Explanation of the sample: 

Reading from right-to-left:
1*1 + 1*-2 + 1*4 + 0*-8 +1*16 + 1*-32 = -13

题意就是给一个数,让你转化成二进制形式的数,只不过这一次的权值不是2的n次方而是-2的n次方。

这个需要好好观察一下hint,发现当前的权值存不存在,只要对下一个权值取余就知道了,如果余数为0,那么当前这个数自然是后面一个权值的倍数了,取0,否则就取1.

然后减去当前权值,继续往后走。

最后减到0就可以了。

注意要用long long 跟普通二进制是不同的!

注意n为0的情况!!

#include <cstdio>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;
const int MAXN=1e5+7;
const int inf =1e9;
int ans[1000];
long long n;
long long pw(int a,int b)
{
    long long sum=1;
    long long base=a;
    while(b)
    {
        if(b&1)sum*=base;
        base*=base;
        b>>=1;
    }
    return sum;
}
int main()
{
    scanf("%lld",&n);
    int top=0;
    if(!n)ans[top++]=0;
    while(n)
    {
        if(n%(pw(-2,top+1)))ans[top]=1;
        else ans[top]=0;
        n-=ans[top]*pw(-2,top);
        top++;
    }
    while(top)printf("%d",ans[--top]);
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值