POJ 3122 pie 二分

Time Limit:1000MS Memory Limit:65536K
Total Submissions:9653 Accepted:3478 Special Judge

    Description

346x232 My birthday is coming up and traditionally I"m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

    My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

    What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

    Input

One line with a positive integer: the number of test cases. Then for each test case:One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

    Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 ?3 .

    Sample Input

33 34 3 31 24510 51 4 2 3 4 5 6 5 4 2

    Sample Output

25.13273.141650.2655


有n块蛋糕,分给f+1个人,但是每个人必须是整块(不能来自不同的两块蛋糕)。

思路:二分法,答案在总体积除以人数(sum/(f+1))到0之间寻找,满足条件切精确度足够则范围值。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
#include <map>
#include<queue>
#define pi 3.14159265359
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,f;
        double v[10005],max=0,mid=-10000,min=0;
        cin>>n>>f;
        for(int i=0;i<n;i++)
        {
            cin>>v[i];
            v[i]=v[i]*v[i]*pi;
            max+=v[i];
        }
        max=max/(f+1);
        while(fabs(min-max)>0.0001)
        {
            int sum=0,flag=1;
            mid=(max+min)/2;
            for(int i=0;i<n;i++)
            {
                sum+=(int)floor(v[i]/mid);
                if(sum>=f+1)
                {
                    min=mid;
                    flag=0;
                    break;
                }
            }
            if(flag) max=mid;
        }
        printf("%.4lf\n",min);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值