hrbust1530 pie

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 



My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different. 
Input
One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3 . 
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655


题意大概是m+1个人分n个pie,每个人分得的pie只能来自同一个pie。即我可以把一个pie切成几份给别人,但一个人不能收到超过一份pie。

因为我要找一个适当的大小,且可证只有唯一确定的一个大小使得最后每个人分得的最大。故用二分查找,左边界是0,又边界是最大的“面积”,(不是半径)。

最后乘pi,以保证精度。


#include<iostream>
#include<cstdio>
#include<string.h>
#include<math.h>
#include<string>
#include<map>
#include<set>
#include<vector>
#include<algorithm>
#include<queue>
#include<iomanip>
using namespace std;
const int INF = 0x3f3f3f3f;
const int NINF = 0xc0c0c0c0;

const double eps = 1e-8;
const double pi = acos(-1);    //define pi
int n,m;
int s[10000+5] = {0};
bool judge(double mid)
{
    int cnt = 0;
    for(int i=0;i<n;i++){
        if(s[i] >= mid){
            cnt += (int)( s[i]/mid);
        }
    }
    return cnt>=m+1;
}
int main()
{
    int T;
    cin >> T;
    while(T--){
        memset(s,0,sizeof(s));
        int maxs = -1;
        cin >> n >> m;
        for(int i=0;i<n;i++){
            int temp;
            cin >> temp;
            s[i] = temp*temp;
            maxs = max(maxs,s[i]);
        }
        double left =0.0 ,right = maxs*1.0;
        while(left+eps < right){
           double mid = (left+right)/2.0;
            if(judge(mid)){
                left = mid;
            }
            else{
                right = mid;
            }
        }
        cout << fixed << setprecision(4) << left*pi << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值