hdu 2689 sort it (树状数组 逆序数)

题目:点击打开链接


树状数组处理逆序对,自底向下存的是出现次数。

Sort it

Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 
Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 
Sample Input
 
 
31 2 34 4 3 2 1
 
Sample Output
 
 
06
#include<stdio.h>
#include<string.h>
int n,tree[100005];

int lowbit(int i){
    return i&(-i);
}

void update(int i,int x){
    while(i<=n){             
        tree[i]+=x;
        i+=lowbit(i);
    }
}

//加入第i个数,多产生了i个序对,query(a)表示前i个数中小于等于a的数字个数(即之前update有没有更新到前面去)
//i-query(a)表示加入a[i]产生的逆序对数
int query(int i){
    int sum=0;
    while(i>0){
        sum+=tree[i];
        i-=lowbit(i);
    }
    return sum;
}
main(){
    int i,a,ans=0;   /*全局变量定义了就不要再定义了,否则就成了局部变量*/
    while(scanf("%d",&n)!=EOF){
        ans=0;
        memset(tree,0,sizeof(tree));
        for(i=1;i<=n;i++){
            scanf("%d",&a);
            update(a,1);
            ans+=i-query(a);
        }
        printf("%d\n",ans);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值