hdu 2689 Sort it【逆序数+树状数组】

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
Output
For each case, output the minimum times need to sort it in ascending order on a single line.
Sample Input
3
1 2 3
4
4 3 2 1
Sample Output
0
6

题意:把一个具有n个不同元素的序列,只能交换两个相邻的位置的元素,问最少交换多少次变成升序序列。
思路:对于当前第i位置元素x,只需要query出【1, i - 1】比其大的元素个数。换种思考,升序序列中元素x前的x-1个数去哪了呢?比x早出现的就不用挪了,所以问题转化为:i - 【1,x - 1】出现的个数。出现与否01表示,用树状数组(线段树亦可)统计前x个数的和就行了。

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;

const int MAXN = 1000 + 10;
int a[MAXN];
int n;

int lowbit(int x) {
    return x & (-x);
}

inline void update(int i, int x) {
    while(i <= n) {
        a[i] += x;
        i += lowbit(i);
    }
}

inline int query(int x) {
    int sum = 0;
    while(x > 0) {
        sum += a[x];
        x -= lowbit(x);
    }
    return sum;
}

int main() {
    while(~scanf("%d", &n)) {
        memset(a, 0, sizeof(a));
        int sum = 0, x;
        for(int i = 1; i <= n; ++i) {
            scanf("%d", &x);
            update(x, 1);
            sum += i - query(x);
        }
        printf("%d\n", sum);
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值