hdu 2689 Sort it(树状数组)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2689点击打开链接


Sort it

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4693    Accepted Submission(s): 3261


Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 

Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 

Sample Input
  
  
3 1 2 3 4 4 3 2 1
 

Sample Output
  
  
0 6
 
暴力可以过的题 用树状数组求逆序对写了下
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include<algorithm>
#include <math.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <queue>
#include <stack>
#include <set>
#include <vector>
using namespace std;
int tree[1000000];
int lowbit (int x)
{
    return x&-x;
}
int getsum(int x)
{
    int sum=0;
    while(x>0)
    {
        sum+=tree[x];
        x-=lowbit(x);
    }
    return sum;
}
void add(int x,int num)
{
    while(x<1000000)
    {
        tree[x]+=num;
        x+=lowbit(x);
    }
}
int main()
{
    int n=0;int s=0;
    while(~scanf("%d",&n))
    {
        s=0;
        memset(tree,0,sizeof(tree));
        for(int i=0;i<n;i++)
        {
            int nn=0;
            scanf("%d",&nn);
            add(nn,1);
            s+=(getsum(n)-getsum(nn));
        }
        cout << s << endl;
    }

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值