poj 1990 MooFest(树状数组变形)



MooFest
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7054 Accepted: 3171

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. 

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. 

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57

题目大意:一群牛参加完牛的节日后都有了不同程度的耳聋,第i头牛听见别人的讲话,别人的音量必须大于v[i],当两头牛i,j交流的时候,交流的最小声音为max{v[i],v[j]}*他们之间的距离。现在有n头牛,求他们之间两两交流最少要的音量;

思路:挂在树状数组专题里。。否则还真的想不到用树状数组做。。。最开始我想的思路是,用结构体存每个点的x,跟v,然后按照v从小到大排序,这样从前面往后枚举的每一个点肯定是当前点最大的,用这个点乘以这个点跟别的点的差的和就好了,关于差的和我一开始想的是直接用现在存在的所有点的坐标和-去当前点x*存在的点的数量。。。点的数量用树状数组维护。。点坐标的和也用树状数组维护。。(我为什么要用树状数组呢?直接一个变量记录点的和不就好了。。。因为后面的点肯定要跟前面点连一次,前面的点不可能跟后面的点连,因为前面的v小。。,所以后面的点肯定跟前面所有点连一次),但是这样直接减是不对的。。。因为距离是两个点相减的绝对值。。用一个变量记录其他现在存在点坐标的和,肯定有比当前点坐标小的,这样一减就是负的了。。。

所以要分情况,先找出在当前点前面的点,以及坐标和,用当前点x*前面点的数量减去前面点的和,就是“绝对值”了。后面的点的数量就是i - 前面的点 - 1(本身),后面点的和就是现在所有点的和(除了当前点)- 减去前面点的和;

和。

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn = 1e5;
int c[maxn], sum[maxn], n;
struct node
{
    int x, v;
    bool operator < (const node &a) const
    {
        return v < a.v;
    }
}a[maxn];
int lowbit(int k)
{
    return k & -k;
}
void update1(int pos, int val)
{
    while(pos < maxn)
    {
        c[pos] += val;
        pos += lowbit(pos);
    }
}
void update2(int pos, int val)
{
    while(pos < maxn)
    {
        sum[pos] += val;
        pos += lowbit(pos);
    }
}
int sum1(int pos)
{
    int ans = 0;
    while(pos)
    {
        ans += c[pos];
        pos -= lowbit(pos);
    }
    return ans;
}
int sum2(int pos)
{
    int ans = 0;
    while(pos)
    {
        ans += sum[pos];
        pos -= lowbit(pos);
    }
    return ans;
}
int main()
{
    while(~scanf("%d", &n))
    {
        memset(c, 0, sizeof(c));
        memset(sum, 0, sizeof(sum));
        for(int i = 1; i <= n; i++)
            scanf("%d%d",&a[i].v, &a[i].x);
        sort(a+1, a+1+n);
        long long ans = 0, tempsum = 0;
        for(int i = 1; i <= n; i++)
        {
        //  tempsum += a[i].v;
            int r = sum1(a[i].x);//记录个数
            int t = sum2(a[i].x);//记录坐标和
            ans += a[i].v*(r*a[i].x-t+tempsum-t-(i-r-1)*a[i].x);
            tempsum += a[i].x;    //这样保证除了当前点
            update1(a[i].x, 1);
            update2(a[i].x, a[i].x);
        }
        printf("%lld\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值