题目1439:Least Common Multiple

题目1439:Least Common Multiple

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:5958

解决:1774

题目描述:

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入:

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出:

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入:
2
3 5 7 15
6 4 10296 936 1287 792 1
样例输出:
105
10296
题目链接:http://ac.jobdu.com/problem.php?pid=1439
代码实现:
#include <iostream>
#include<stdio.h>
#include<string.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;

int gcd(int a,int b){
	if( a== 0 && b==0){
		return -1;
	}else if(a ==0 || b==0){
		return a+b;
	}else {
		return gcd(b,a%b);
	}
}
int lcm(int a,int b){
	/*
	a、b的最小公倍数=(a*b)/a、b的最大公约数 
	*/
	int gcdm=gcd(a,b);
	if(gcdm == -1){
		return -1;  //a=0 b=0 不存在最大公约数 
	}else{
		return a/gcdm*b;
	} 	
}

int main(int argc, char *argv[]) {
	int n;
	while(cin>>n){
		while(n--){
			int num[100];
			memset(num,0,100);
			
			int length;
			cin>>length;  //数字的个数
			
			for(int i=0;i<length;i++){
				cin>>num[i];
			} 
			
			//3.两两求出LCM
			int ans;
			ans=num[0];
			for(int i=1;i<length;i++){
				ans=lcm(ans,num[i]);
			}
			cout<<ans<<endl;
		}	
	}	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值