1649: [Usaco2006 Dec]Cow Roller Coaster

1649: [Usaco2006 Dec]Cow Roller Coaster

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 636   Solved: 319
[ Submit][ Status][ Discuss]

Description

The cows are building a roller coaster! They want your help to design as fun a roller coaster as possible, while keeping to the budget. The roller coaster will be built on a long linear stretch of land of length L (1 <= L <= 1,000). The roller coaster comprises a collection of some of the N (1 <= N <= 10,000) different interchangable components. Each component i has a fixed length Wi (1 <= Wi <= L). Due to varying terrain, each component i can be only built starting at location Xi (0 <= Xi <= L-Wi). The cows want to string together various roller coaster components starting at 0 and ending at L so that the end of each component (except the last) is the start of the next component. Each component i has a "fun rating" Fi (1 <= Fi <= 1,000,000) and a cost Ci (1 <= Ci <= 1000). The total fun of the roller coster is the sum of the fun from each component used; the total cost is likewise the sum of the costs of each component used. The cows' total budget is B (1 <= B <= 1000). Help the cows determine the most fun roller coaster that they can build with their budget.

奶牛们正打算造一条过山车轨道.她们希望你帮忙,找出最有趣,但又符合预算的方案.  过山车的轨道由若干钢轨首尾相连,由x=0处一直延伸到X=L(1≤L≤1000)处.现有N(1≤N≤10000)根钢轨,每根钢轨的起点Xi(0≤Xi≤L- Wi),长度wi(l≤Wi≤L),有趣指数Fi(1≤Fi≤1000000),成本Ci(l≤Ci≤1000)均己知.请确定一种最优方案,使得选用的钢轨的有趣指数之和最大,同时成本之和不超过B(1≤B≤1000).

Input

* Line 1: Three space-separated integers: L, N and B.

 * Lines 2..N+1: Line i+1 contains four space-separated integers, respectively: Xi, Wi, Fi, and Ci.

    第1行输入L,N,B,接下来N行,每行四个整数Xi,wi,Fi,Ci.

Output

* Line 1: A single integer that is the maximum fun value that a roller-coaster can have while staying within the budget and meeting all the other constraints. If it is not possible to build a roller-coaster within budget, output -1.

Sample Input

5 6 10
0 2 20 6
2 3 5 6
0 1 2 1
1 1 1 3
1 2 5 4
3 2 10 2


Sample Output

17
选用第3条,第5条和第6条钢轨

HINT

Source

Silver





。。。。。。

也是醉了。一道DP水题,竟然wa了这么多次,下回一定要注意细节。。。。。。

懒得写方程了,自己看代码吧,就随便背包一下。。。。。


附代码:


#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<climits>
#include<cstring>
#include<fstream>
#include<queue>
#include<map>
#include<set>
#include<climits>
#define N 10010
#define M 1001
using namespace std;
typedef long long ll;
int L,n,B;
int f[M][M],ans;
struct node{int l,r,f,c;}p[N];
bool operator < (node a,node b)
{return a.r==b.r?a.l<b.l:a.r<b.r;}
int main()
{
	scanf("%d%d%d",&L,&n,&B);
	memset(f,-1,sizeof(f));
	for(int i=1;i<=n;i++)
		{
			int x,w,f,c;
			scanf("%d%d%d%d",&x,&w,&f,&c);
			p[i].l=x,p[i].r=x+w,p[i].f=f,p[i].c=c;
		}sort(p+1,p+1+n);
	f[0][0]=0;
	for(int u=1;u<=n;u++)
		{
			for(int j=B;j>=p[u].c;j--)
				if(f[p[u].l][j-p[u].c]!=-1)f[p[u].r][j]=max(f[p[u].r][j],f[p[u].l][j-p[u].c]+p[u].f);
		}int ans=-1;
	for(int i=0;i<=B;i++)ans=max(ans,f[L][i]);
	printf("%d\n",ans);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值