1662: [Usaco2006 Nov]Round Numbers 圆环数 Time Limit: 5 Sec Memory Limit: 64 MB Submit: 337 Solved:

1662: [Usaco2006 Nov]Round Numbers 圆环数

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 337   Solved: 194
[ Submit][ Status][ Discuss]

Description

正如你所知,奶牛们没有手指以至于不能玩“石头剪刀布”来任意地决定例如谁先挤奶的顺序。她们甚至也不能通过仍硬币的方式。 所以她们通过"round number"竞赛的方式。第一头牛选取一个整数,小于20亿。第二头牛也这样选取一个整数。如果这两个数都是 "round numbers",那么第一头牛获胜,否则第二头牛获胜。 如果一个正整数N的二进制表示中,0的个数大于或等于1的个数,那么N就被称为 "round number" 。例如,整数9,二进制表示是1001,1001 有两个'0'和两个'1'; 因此,9是一个round number。26 的二进制表示是 11010 ; 由于它有2个'0'和 3个'1',所以它不是round number。 很明显,奶牛们会花费很大精力去转换进制,从而确定谁是胜者。 Bessie 想要作弊,而且认为只要她能够知道在一个指定区间范围内的"round numbers"个数。 帮助她写一个程序,能够告诉她在一个闭区间中有多少Hround numbers。区间是 [start, finish],包含这两个数。 (1 <= Start < Finish <= 2,000,000,000)

Input

* Line 1: 两个用空格分开的整数,分别表示Start 和 Finish。

Output

* Line 1: Start..Finish范围内round numbers的个数

Sample Input

2 12

Sample Output

6

输出解释:

2 10 1x0 + 1x1 ROUND
3 11 0x0 + 2x1 NOT round
4 100 2x0 + 1x1 ROUND
5 101 1x0 + 2x1 NOT round
6 110 1x0 + 2x1 NOT round
7 111 0x0 + 3x1 NOT round
8 1000 3x0 + 1x1 ROUND
9 1001 2x0 + 2x1 ROUND
10 1010 2x0 + 2x1 ROUND
11 1011 1x0 + 3x1 NOT round
12 1100 2x0 + 2x1 ROUND

HINT

Source

Silver




dp方程搞出来容易,难点在搞细节。。。。
附代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
using namespace std;
int f[51][51];
int st,ed,ans;
int n,m,t[51];
void init()
{
	for(int i=0;i<=50;i++)f[i][0]=1;
	for(int i=1;i<=50;i++)
		for(int j=1;j<=i;j++)
			f[i][j]=f[i-1][j]+f[i-1][j-1];
}
int cal(int x,int y)
{
	int ret=0;
	for(int i=0;i<=x;i++)
		if(i>=x-i+y)
			ret+=f[x][i];
	return ret;
}
int get(int x)
{
	if(!x)return 0;
	int len=0;
	while(x)
		{
			t[++len]=x&1;
			x>>=1;
		}
	int tmp=0;
	for(int i=1;i<len;i++)
		tmp+=cal(i-1,1);
	int duo=1;len--;
	while(len)
		{
			if(t[len]==1)tmp+=cal(len-1,duo-1);
			duo+=t[len]?1:-1;len--;
		}
	tmp+=duo<=0;return tmp;
}

int main()
{
	init();
	scanf("%d%d",&st,&ed);	
	printf("%d\n",get(ed)-get(st-1));
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值