1655: [Usaco2006 Jan] Dollar Dayz 奶牛商店

1655: [Usaco2006 Jan] Dollar Dayz 奶牛商店

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 477   Solved: 253
[ Submit][ Status][ Discuss]

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 1 @ US$3 + 1 @ US$2 1 @ US$3 + 2 @ US$1 1 @ US$2 + 3 @ US$1 2 @ US$2 + 1 @ US$1 5 @ US$1 Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

    约翰到奶牛商场里买工具.商场里有K(1≤K≤100).种工具,价格分别为1,2,…,K美元.约翰手里有N(1≤N≤1000)美元,必须花完.那他有多少种购买的组合呢?

Input

A single line with two space-separated integers: N and K.

    仅一行,输入N,K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

    不同的购买组合数.

Sample Input

5 3

Sample Output

5

HINT

Source

Silver



背包水题。
f[i][j]表示用前j-1个数分解i的方案数,则:f[i][j]=f[i][j-1],f[i-j*u][j-1]。
显然第二维可以去掉。。
数据大,加个加法高精度就好了。

附代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<climits>
#include<cstdlib>
#include<cstring>
#include<string>
#include<fstream>
#include<queue>
#include<map>
#include<set>
#include<stack>
#define N 1001
using namespace std;
int n,k;
int f[N];
struct node{int a[50],len;}p[N];
void add(node &a,node &b)
{
	node c;int lenc=0;
	for(int i=0;i<=49;i++)c.a[i]=0;
	for(int i=1;i<=min(a.len,b.len);i++)
		{
			c.a[i]+=a.a[i]+b.a[i];
			if(c.a[i]>9)c.a[i]-=10,c.a[i+1]++;
		}int j=min(a.len,b.len)+1;lenc=j-1;
	while(j<=a.len)
		{
			c.a[j]+=a.a[j];
			if(c.a[j]>9)c.a[j]-=10,c.a[j+1]++;
			j++;lenc=a.len;
		}
	while(j<=b.len)
		{
			c.a[j]+=b.a[j];
			if(c.a[j]>9)c.a[j]-=10,c.a[j+1]++;
			j++;lenc=b.len;
		}if(c.a[j])lenc++;c.len=lenc;
	a=c;
}
int main()
{
//	freopen("in.txt","r",stdin);
//	freopen("my.txt","w",stdout);
	p[0].len=1,p[0].a[1]=1;for(int i=2;i<=49;i++)p[0].a[i]=0;
	scanf("%d%d",&n,&k);
	for(int j=1;j<=k;j++)
		for(int i=n;i>=j;i--)
			for(int u=1;u*j<=i;u++)
				add(p[i],p[i-u*j]);
	for(int i=p[n].len;i;i--)printf("%d",p[n].a[i]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值