NYOJ - 218 - Dinner(简单问题)

描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示
The tableware only contains: bowl, knife, fork and chopsticks.

题目意思是给出一些盒子,盒子上面写着盒子里面有什么东西,其中餐具有bowl, knife, fork and chopsticks,输入一些盒子上的文字,输出这些文字中是餐具的所有盒子上写的字。

思路:这道题被标记为贪心,看到时间限制100ms,于是想是否只需要判断单词的开头一个字母就能判断单词是否相同。但是题目中并没有说明这样的信息。于是按照题目意思,循环输入string ,然后判断是否是餐具。提交后,运行超时。观察程序后,并没有发现能优化的地方,只是输入用的是cin,于是把string类型换成了char数组,用scanf()输入。提交后,AC。本来还想:是否相同的餐具只需要输出一次,看来是自己想多了。

 

 
#include<cstdio>
#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
int n;
char s[1000];
int main(){
	while(scanf("%d",&n)!=EOF){
	
		for(int i=0 ;i<n ;i++){
			scanf("%s",s);
			if(strcmp(s,"chopsticks")==0){
				cout<<"chopsticks ";
				continue;	
			}
			
			if(strcmp(s,"bowl")==0){
				cout<<"bowl ";	
				continue;
			}
			
			if(strcmp(s,"knife")==0){
				cout<<"knife ";		
				continue;
			}
					
			if(strcmp(s,"fork")==0){
				cout<<"fork ";
				continue;	
			}
				
		}
		puts("");
	}
	
	
	return 0;
}        



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值