图论之最小生成树-Agri-Net

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

这题是比较典型的最小生成树,主要是先找离第一个小岛最近的点,把他们合并成一个再找离他们最近的点,并确保该点还没有被连进去且不正好是该点,这样依次弄下去,弄n-1次就好

#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<bitset>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn=110;
int a[maxn][maxn];
int low[maxn];
int check[maxn];

int main()
{
	int i,j,t,s;
	int n;
	while(~scanf("%d",&n))
	{
		int ans=0;
		int min=0x3f3f3f3f;
		memset(check,0,sizeof(check));
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				scanf("%d",&a[i][j]);
		for(i=2;i<=n;i++)
		{
			low[i]=a[1][i];
		}
		check[1]=1;
		for(t=1;t<=n-1;t++)
		{
			min=0x3f3f3f3f;
			for(i=2;i<=n;i++)
			{
				if(low[i]<min&&!check[i]&&s!=i)
				{
					min=low[i];
					s=i;
				}
			}
			check[s]=1;
			ans+=min;
			for(i=2;i<=n;i++)
			{
				if(!check[i]&&a[s][i]<low[i])
					low[i]=a[s][i];
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}
因为我是新手所以我刚上来想用最短路径来求,后来发现错了,为什么错了?因为本题只是求一个点到离他最近的点的距离就行了,首先最短路求出来的东西本来就肯定用不着
因为a[i][k]肯定比a[i][j]小,既然如此,只看到第i个点从1到i-1个点中到哪个点距离最小直接加起来又为什么不行?用这个方法不包含,假设2点离4点最近,4点又离3点最近,3-1,这样类似的情况,应该选择距离最短的那个点,并且排除该点与其构成回路的情况,这样就变成最小生成树了。。。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值