HDU 2846Repository(字典树+计数)

Repository

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/65536K (Java/Other)
Total Submission(s) : 17   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.

Input

There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.

Output

For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.

Sample Input

20
ad
ae
af
ag
ah
ai
aj
ak
al
ads
add
ade
adf
adg
adh
adi
adj
adk
adl
aes
5
b
a
d
ad
s

Sample Output

0
20
11
11
2

Source

2009 Multi-University Training Contest 4 - Host by HDU
想法:
在字典树上计数,注意防止多个重复计数
代码:
#include<stdio.h>
#include<string.h>
using namespace std;
const int N=26;
struct Trie
{
    int flag;
    int num;
    Trie *nx[N];
};
Trie *root;
void init (Trie *t)
{
    for (int j = 0; j < N; ++j) //初始化
    {
        t->nx[j] = NULL;
    }
     t->num = 0;
    t->flag = -1;
}
void Insert (char str[],int Id)//插入单词
{
    Trie *p = root;
    int len = strlen (str);
    for (int i = 0; i < len; ++i)
    {
        int id = str[i] - 'a';
        if (p->nx[id] == NULL)
        {
            Trie *t = new Trie;
            init(t);
            p->nx[id] = t;
        }
        p=p->nx[id];
        if(p->flag!=Id)
        {
        p->flag=Id;
        p->num++;
        }

    }
}
int Find(char str[])
{
    Trie *p = root;
    int len = strlen(str);
    for (int i = 0;i < len;++i)
    {
        int id = str[i] - 'a';
        if (p->nx[id] == NULL) return 0;
        p = p->nx[id];
    }
    return p->num;
}
void Delete(Trie *t)
{
    for (int i = 0;i < N;++i)
    {
        if (t->nx[i]!=NULL) Delete(t->nx[i]);
    }
    delete t;
}
int main()
{
     root = new Trie;
    init(root);
    int T,n,k;
    scanf("%d",&T);
    getchar();
    int i,j;
    char s[21];
    for(i=0;i<T;i++)
    {
     scanf("%s",s);
    for(j=0;j<strlen(s);j++)
        {
          Insert(s+j,i);
        }
    }
    scanf("%d",&n);
    getchar();
    for(i=0;i<n;i++)
    {
       scanf("%s",s);
       printf("%d\n",Find(s));
    }
    Delete(root);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值