HDU4734[F(x)]

Problem Description:

For a decimal number x with n digits (AnAn-1An-2 … A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + … + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).

Input:

The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)

Output:

For every case,you should output “Case #t: ” at first, without quotes. The t is the case number starting from 1. Then output the answer.

Sample Input:

3
0 100
1 10
5 100

Sample Output:

Case #1: 1
Case #2: 2
Case #3: 13

题目大意:给出一个值A,求0~B中F(x)值小于A的个数

题解:用f[pos][sum]来表示在pos位还需要拼凑出的sum值

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int a[15], dp[15][5000];
int A, B;
int dfs( int pos, int sum, int flag ){
    if ( pos < 0 ) return sum >= 0 ;
    if ( sum < 0 ) return 0;
    if ( !flag && dp[pos][sum] != -1 ) return dp[pos][sum];
    int up = flag ? a[pos] : 9, ans = 0;
    for ( register int i = 0; i <= up; i++ )
         ans += dfs( pos-1, sum - i*(1<<pos), flag && i == a[pos] );
    if ( !flag ) dp[pos][sum] = ans;
    return ans;
}

int F( int x ){
    int sum = 0;
    for ( int len = 0; x; len++) sum += ( x % 10 ) * ( 1 << len ), x /= 10;
    return sum; 
}

int solve( int x, int y ){
    int pos = 0;
    for ( ; x; a[pos++] = x % 10, x /= 10);
    return dfs( pos-1, F(y), 1);
}
int main(){
    int T;
    memset( dp, -1, sizeof(dp) );
    scanf( "%d", &T);
    for ( int i = 1; i <= T; i++){
        scanf( "%d%d", &A, &B);
        printf( "Case #%d: %d\n", i, solve( B, A ) );
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值