HDU-4734-F(x)

Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

Source

一道很简单的数位DP!!!!DP[pos][sum] 记录的是长度为pos小于等于sum的个数,这样就不用每次都初始化,我一开始DP记录的是长度为pos,前len-pos个数和sum的个数,因为每组样例DP的值不一定相同 如 1 10 dp[0][0] = 1; 而 2 100 dp[0][0] = 2;因此每次都需要初始化,这也是导致超时的原因。
这是一道很好的DP题!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
int dp[12][4600];
int A,B;
int F;
vector <int> digit;
void init(){
    F = 0;
    int t = 0;
    while(A){
        F += (A%10)*(1<<t);
        t++;
        A/=10;
    }
}
int dfs(int pos,int val,int done){
    if(pos==-1) return 1;
    if(!done&& ~dp[pos][val]) return dp[pos][val];
    int res = 0;
    int end = done?digit[pos]:9;
    for(int i = 0; i <= end; i++){
        if(val + i*(1<<pos) > F) break;
        res += dfs(pos-1,val + i*(1<<pos),done&&i==end);
    }
    if(!done) dp[pos][val] = res;
    return res;
}
int solve(int num){
    digit.clear();
    while(num){
        digit.push_back(num%10);
        num /= 10;
    }
    return dfs(digit.size()-1,0,1);
}
int main(){
    int ncase,T = 1;
    cin >> ncase;
    memset(dp,-1,sizeof dp);
    while(ncase--){
        cin >> A >> B;
        init();
        printf("Case #%d: %d\n",T++,solve(B));
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值