【HDU-4004 】The Frog's Games 【二分+思维】

The annual Games in frogs’ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog’s longest jump distance).
Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Output
For each case, output a integer standing for the frog’s ability at least they should have.
Sample Input
6 1 2
2
25 3 3
11
2
18
Sample Output
4
11

比较简单的二分,很容易就想到枚举 青蛙的能力,找到最小的就可以了。关键就是那个函数,稍微麻烦一点,其他的还好。
代码

#include<bits/stdc++.h>
using namespace std;
const int MAXN = 500000+10 ;
const double pi=acos(-1.0);
const int inf =0x3f3f3f3f;
const double eps =1e-5;
int l,n,m;
int arr[MAXN];
bool f(int x){ // 函数
    int cnt=1; int val=0;
    for(int i=1;i<=n;i++){
        if(arr[i]-val>x&&arr[i-1]-val<=x){
            cnt++; //记录青蛙在当前能力下 要最少跳几次
            val=arr[i-1];
            i--;
        } 
        if(cnt>m) return 0;
    }
    return cnt!=1; // 也有可能一个都跳不过去
}
//上面的函数,我写的有点乱,看网上别人的方法不错,一起放这里
/*bool ff(int x){
    int cnt=0;int last=0; // 这里找个数的方法还是比较通俗易懂
    for(int i=1;i<=n+1;){// 注意这里的下标开始为1if(arr[i]-last<=x) i++;
        else {
            if(arr[i-1]==last) return false;
            last=arr[i-1];
            cnt++;
        }
    }
    cnt++;
    return cnt<=m;
}*/
int main(){
       while(~scanf("%d%d%d",&l,&n,&m)){
         for(int i=0;i<n;i++)
            scanf("%d",&arr[i]);
        if(n==0||m==1) printf("%d\n",l); //特殊情况
        else{
            int le=0;int ri=l;
            arr[n]=l;//其实是有n+1个台子。
            sort(arr,arr+1+n);
            int ans=0;
            while(le<=ri){ 
                int mid=(ri+le)>>1;
                if(f(mid)) {ans=mid;ri=mid-1;}
                else le=mid+1;
             }
            printf("%d\n",ans);
         }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值