POJ 1861 Network(最小生成树+克鲁斯卡尔)

55 篇文章 0 订阅
13 篇文章 0 订阅

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 
Input
The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10  6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.
Output
Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.
Sample Input
4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1
Sample Output
1
4
1 2
1 3
2 3
3 4


题解:

给一堆边,让你连通所有节点使得最长的边的值最小,直接克鲁斯卡尔搞搞搞就出来了,注意有些人说这题的案例有问题,其实是没有问题的,这题是specil judge,只要你输出的是全部连通而且最短的是要求值就行了,这题输出的边可以是3也可以是4

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
using namespace std;
#define lson k*2
#define rson k*2+1
#define M (t[k].l+t[k].r)/2
#define INF 1008611111
#define ll long long
#define eps 1e-15
int pre[1005];
int find(int x)
{
    if(x!=pre[x])
        pre[x]=find(pre[x]);
    return pre[x];
}
struct edge
{
    int f,t;//存边
    int v;
}a[15005];
int cmp(edge x,edge y)
{
    return x.v<y.v;//从小到大排序
}
int xx[1005];//存输出的点对
int yy[1005];
int main()
{
    int i,j,k,n,m,maxx,d1,d2;
    scanf("%d%d",&n,&m);
    for(i=0;i<m;i++)
    {
        scanf("%d%d%d",&a[i].f,&a[i].t,&a[i].v);
    }
    sort(a,a+m,cmp);
    for(i=1;i<=n;i++)//初始化根
        pre[i]=i;
    int ans=0;
    maxx=0;
    for(i=0;i<m;i++)
    {
        d1=find(a[i].f);
        d2=find(a[i].t);//并查集操作
        if(d1!=d2)
        {
            xx[ans]=a[i].f;
            yy[ans]=a[i].t;
            pre[d2]=d1;
            if(maxx<a[i].v)
                maxx=a[i].v;
            ans++;
        }
        if(ans>=n-1)
            break;
    }
    printf("%d\n%d\n",maxx,ans);
    for(i=0;i<ans;i++)
    {
        printf("%d %d\n",xx[i],yy[i]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值