Y2K Accounting Bug poj

Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15319 Accepted: 7678

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit
题解:
公司亏损与盈利;
该公司一年12个月有亏算有盈利,规则是:一年每五个月数据报表是亏损,也就是1-5,2-6,3-7....一共八分数据,全部显示亏损,请问在此规则下公司怎么在一年中盈利最大值,给出两个数盈利和亏损;
简单,贪心即可,五月算一次,1-5个月中有亏损,2-6中也有亏损,3-7也有,想让盈利最大值就是让亏损尽可能小,那么每五个月既然决定亏损就尽量吧亏损的月份往后放(因为1-5,2-6有四个重叠月份,和3-7有两个,因此把亏损往后放才能让这颗亏损发挥它的最大价值,最多福泽五分数据,因次知道这层贪心开始写代码就ok了 )
ac 代码
#include<stdio.h>
int main()
{
	int mouth,i,k,j,t;
	int s,d,sum;
	while(scanf("%d%d",&s,&d)!=EOF)
	{
		int a[12]={1,1,1,1,1,1,1,1,1,1,1,1};
		sum=0;
		for(i=0;i<8;i++)
		{
			k=i;
			t=j=0;		
			while(k<i+5)
			{
				if(a[k]==1)
					t++;
				else j++;
				k++;
			}	
			int u=j;	
			while(t*s-j*d>=0)
			{
				t--;
				j++;	
			}
			if(j>u)
			{
				j=j-u;
			}
			else j=0;
			k=i+4;
	
			while(j--)
			{
				a[k]=0;
				k--;
			}
		}
		for(i=0;i<12;i++)
		{
			if(a[i])
				sum+=s;
			else sum-=d;
		}
		if(sum<=0)
			printf("Deficit\n");
		else printf("%d\n",sum);
	}
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值