Task HDU 4864

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7278    Accepted Submission(s): 1921


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1

Sample Output
  
  
1 50004
    
    
题目大意+解析:
任务分配,有若干任务,若干机器,都有俩属性,时间和复杂度;需要用这些机器把这些任务一个个完成,规则:一台机器一天只能完成一个任务,当机器的时间和复杂度都高于任务是任务才被完成,给出机器和时间的具体情况,请问一天最多完成多少任务;
贪心!把机器合理运用保证任务的最大完成量;
刚开始应该会想到用两层for循环来解决问题,但是看一下N和M的取值,超时是一定的,换种思路贪心解决;
首先可以先把机器和任务先按逆序排序,用逆序的原因是我先要先把时间这个因素排除掉,只取留下来的复杂度来比较,
因为是逆序所以第一个任务的时间一定是最大的,遍历查找一下机器中大于等于这个最大时间的机器,用一个复杂度数组来存放这些查找到的机器(此刻可以不必关心时间是多少,反正大于最大时间,剩下的时间都不必考虑,一定满足,所以只剩下复杂度一个判断条件),找到所有满足该任务的时间要求的机器后,判断复杂度是否满足,思路就是这样,第一个任务结束就开始第二个任务,循环即可
AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct Team{
	int xi,yi;
};
bool cmp(Team x,Team y)
{
	if(x.xi==y.xi)
	return x.yi>y.yi;
	return x.xi>y.xi;
}
int main()
{
	int n,m;
	Team pm[100005],pt[100005];
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int j,i,task=0;
		int level[110]={0};
		long long money=0;		
		for(i=0;i<n;i++)
		scanf("%d%d",&pm[i].xi,&pm[i].yi);
		for(i=0;i<m;i++)
		scanf("%d%d",&pt[i].xi,&pt[i].yi);
		sort(pt,pt+m,cmp);
		sort(pm,pm+n,cmp);
		j=0;
		for(i=0;i<m;i++)
		{
			while(j<n&&pt[i].xi<=pm[j].xi)
			{
				level[pm[j].yi]++;
				j++;
			}
		for(int k=pt[i].yi;k<=100;k++)
			if(level[k])
			{
				money+=pt[i].xi*500+pt[i].yi*2;
				task++;
			level[k]--;
				break;
			}
		}
		printf("%d %I64d\n",task,money);
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值