Buildings HDU 4296

Buildings

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4258    Accepted Submission(s): 1579


Problem Description
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.
 

Input
  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i, s i <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
 

Sample Input
      
      
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output
      
      
1 0 2
题目大意:
建高楼:
建一个多少层的楼层,每层楼有一个pdv,和重量两个属性,判断那种排列顺序的代表pdv最小;
首先给出楼层信息,有多种排列次序,最好的排列顺序就是把weight+pdv做大的放在最下边(单独把最重的或者最能抗的放在最下边都还是不妥的
,唯有综合两种之和才是最合适的,可以自己验证),找到这种方式后,依次求一下各楼层的楼上总weight-改成pdv,求出最大值;
#include<iostream>
#include<algorithm>
using namespace std;
struct Floor{
	long long x,y;
};
bool cmp(Floor m,Floor n)
{
	return (m.x+m.y)<(n.x+n.y);
}
int main()
{
	int i,j,n;
	int x;	
	Floor a[100000];
	while(scanf("%d",&n)!=EOF)
	{
		long long sum=0;
		long long min=0;
		for(i=1;i<=n;i++)
		{
			scanf("%Id%Id",&a[i].x,&a[i].y);
		}
		sort(a+1,a+n+1,cmp);
		for(i=1;i<=n;i++)
			{
				min=max(min,sum-a[i].y);
				sum+=a[i].x;
	}
		printf("%I64d\n",min);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值