Y2K Accounting Bug(POJ 2586)(贪心)

题目链接:http://poj.org/problem?id=2586
Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14242 Accepted: 7166
Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input

Input is a sequence of lines, each containing two positive integers s and d.
Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input

59 237
375 743
200000 849694
2500000 8000000
Sample Output

116
28
300612
Deficit
Source

Waterloo local 2000.01.29

题意:输入的一行分别为一年的平均盈利s和平均亏损d,也就是如果一年中哪个月是盈利的,那这个月盈利s,如果哪个月是亏损的,那这个月的亏损是d。现在已知这个公司每连续5个月(1-5,2-6等)都是亏损的。现在问你全年是否可能盈利,如果可以盈利的话,最大盈利是多少,如果亏损的话,直接输出“Deficit”就好了。

题解:先看5个月,由于每5个月都是亏损的,而且要得到最大盈利,所以要尽量让盈利的月多一些,亏损的月少一些。5个月的盈亏情况可以是ssssd,sssdd,ssddd,sdddd,ddddd,所以从第一种情况开始试,直到这5个月的总和是亏损的。为了使盈利最大,要尽量把s多放几个月而且每5个月的循环都像是第一个5个月一样。s要放在前面,这样s就能多放几个月。(代码中有注释)

思考:
1、要看所要的结果是什么,然后根据所要的结果确定贪心思想。由于这道题要最大盈利,所以就先想把s的月搁多一点。
2、由于题目有要求,所以不能12个月全是s,所以根据题目要求修改贪心策略。题中要求每5个月都是亏损的,所以也相当于是看5个月的小贪心,看看这5个月在s放最多情况下是什么样子的。
3、由符合要求的小贪心扩展到整个题。

#include <iostream>

using namespace std;

int main()
{
    int s, d;
    while (cin >> s >> d) {
        int i;
        int sum = 0;
        for (i = 5; i >= 0; i--) {//枚举5个月的情况下最多能放多少盈利月
            int now = s *  i - d * (5 - i);
            if (now < 0) break;
        }
        int a[15];
        for (int j = 1; j <= 5; j++) {//把5个月的情况放好
            if (j <= i) a[j] = s;//把盈利月放在最前面,这样的话11月与12月就更有可能是盈利月
            else a[j] = -d;//-d,‘-’别忘
            sum += a[j];
        }
        for (int j = 6; j <= 12; j++) {
            a[j] = a[j - 5];//由于前面给出了每5个月最多能放的盈利月的数目,所以后面的依次按照前面的一样循环摆放就好了
            sum += a[j];
        }
        if (sum > 0) cout << sum << endl;
        else cout << "Deficit" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值